<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Oromo Protests Continues &#x2d; July 19, 2020</title>
<meta charset="UTF-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://ayyaantuu.org/xmlrpc.php"/>
<link rel="icon" type="image/png" href="https://ayyaantuu.org/wp-content/uploads/2017/12/cropped-ayyaantuu-2.png">
<meta name="robots" content="max-snippet:-1,max-image-preview:standard,max-video-preview:-1"/>
<meta name="description" content="How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna abbaa irrummaa Itoophiyaa&#8230;"/>
<meta property="og:image" content="https://ayyaantuu.org/wp-content/uploads/2020/07/nations.jpg"/>
<meta property="og:image:width" content="640"/>
<meta property="og:image:height" content="480"/>
<meta property="og:image:alt" content="Oromo Protest"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Oromo Protests Continues &#x2d; July 19, 2020"/>
<meta property="og:description" content="How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna abbaa irrummaa Itoophiyaa irratti diriirsuuf irriba dhaba."/>
<meta property="og:url" content="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/"/>
<meta property="article:published_time" content="2020-07-19T12:08+00:00"/>
<meta property="article:modified_time" content="2020-07-19T12:08+00:00"/>
<meta property="og:updated_time" content="2020-07-19T12:08+00:00"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:title" content="Oromo Protests Continues &#x2d; July 19, 2020"/>
<meta name="twitter:description" content="How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna abbaa irrummaa Itoophiyaa irratti diriirsuuf irriba dhaba."/>
<meta name="twitter:image" content="https://ayyaantuu.org/wp-content/uploads/2020/07/nations.jpg"/>
<meta name="twitter:image:width" content="640"/>
<meta name="twitter:image:height" content="480"/>
<meta name="twitter:image:alt" content="Oromo Protest"/>
<link rel="canonical" href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/"/>
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://ayyaantuu.org/","name":"Ayyaantuu Online"}},{"@type":"ListItem","position":2,"item":{"@id":"https://ayyaantuu.org/category/afaan-oromoo/","name":"Afaan Oromoo"}},{"@type":"ListItem","position":3,"item":{"@id":"https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/","name":"Oromo Protests Continues &#8211; July 19, 2020"}}]}</script>
<link rel='dns-prefetch' href='//content.uplynk.com'/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel="alternate" type="application/rss+xml" title="&raquo; Feed" href="https://ayyaantuu.org/feed/"/>
<link rel="alternate" type="application/rss+xml" title="&raquo; Comments Feed" href="https://ayyaantuu.org/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="&raquo; Oromo Protests Continues &#8211; July 19, 2020 Comments Feed" href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/feed/"/>
<script data-wpfc-render="false">advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
(advads_options=window.advads_options||{})["privacy"]={"enabled":"1","consent-method":"0","custom-cookie-name":"","custom-cookie-value":""};</script>
<link rel="stylesheet" type="text/css" href="//ayyaantuu.org/wp-content/cache/wpfc-minified/ko26we51/rkz.css" media="all"/>
<style id='td-theme-inline-css'>@media(max-width:767px){
.td-header-desktop-wrap{display:none;}
}
@media(min-width:767px){
.td-header-mobile-wrap{display:none;}
}</style>
<link rel="stylesheet" type="text/css" href="//ayyaantuu.org/wp-content/cache/wpfc-minified/ffqr0p4x/rkz.css" media="all"/>
<link rel='https://api.w.org/' href='https://ayyaantuu.org/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ayyaantuu.org/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ayyaantuu.org/wp-includes/wlwmanifest.xml"/> 
<script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<style></style>
<style id="tdw-css-placeholder"></style>
<script data-wpfc-render="false">var Wpfcll={s:[],osl:0,scroll:false,i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.osl=Wpfcll.s.length;Wpfcll.ss();if(Wpfcll.s.length > Wpfcll.osl){Wpfcll.ls(false);}},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.scroll=true;Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.scroll=true;Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.scroll=true;Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=0;if(pageload){n=0;}else{n=(w > 800) ? 800:200;n=Wpfcll.scroll ? 800:n;}var er=e.getBoundingClientRect();var t=0;var p=e.parentNode ? e.parentNode:false;if(typeof p.getBoundingClientRect=="undefined"){var pr=false;}else{var pr=p.getBoundingClientRect();}if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){if(p.parentNode){p=p.parentNode;}if(typeof p.getBoundingClientRect=="undefined"){pr=false;}else{pr=p.getBoundingClientRect();}}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(s.c(e,pageload)){if(oc || ot){if(e.tagName=="DIV" || e.tagName=="A"){e.style.backgroundImage="url("+oc+")";e.removeAttribute("data-wpfc-original-src");e.removeAttribute("data-wpfc-original-srcset");e.removeAttribute("onload");}else{if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}if(e.getAttribute("alt") && e.getAttribute("alt")=="blank"){e.removeAttribute("alt");}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("data-wpfc-original-srcset");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){if(typeof window.jQuery !="undefined"){if(jQuery.fn.fitVids){jQuery(e).parent().fitVids({customSelector:"iframe[src]"});}}var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}else{if(e.tagName=="NOSCRIPT"){if(jQuery(e).attr("data-type")=="wpfc"){e.removeAttribute("data-type");jQuery(e).after(jQuery(e).text());}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));var d=Array.prototype.slice.call(document.getElementsByTagName("div"));var a=Array.prototype.slice.call(document.getElementsByTagName("a"));var n=Array.prototype.slice.call(document.getElementsByTagName("noscript"));this.s=i.concat(f).concat(d).concat(a).concat(n);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-16623 single-format-standard td-standard-pack oromo-protests-continues-july-19-2020 global-block-template-1 tdb_template_14238 tdb-template tdc-header-template tdc-footer-template td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav">
<div class="td-mobile-container">
<div class="td-menu-socials-wrap">
<div class="td-menu-socials"></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content">
<div class="menu-primary_menu-container"><ul id="menu-primary_menu" class="td-mobile-main-menu"><li id="menu-item-812" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-812"><a href="http://ayyaantuu.org">Home</a></li> <li id="menu-item-745" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-745"><a href="https://ayyaantuu.org/category/afaan-oromoo/">Afaan Oromoo</a></li> <li id="menu-item-746" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-746"><a href="https://ayyaantuu.org/category/amharic/">Amharic</a></li> <li id="menu-item-747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-747"><a href="https://ayyaantuu.org/category/english/">English</a></li> <li id="menu-item-748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://ayyaantuu.org/category/human-rights/">Human Rights</a></li> <li id="menu-item-4069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4069"><a href="http://ayyaantuu.org/category/odaa-post/">Scholars</a></li> <li id="menu-item-13422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13422"><a href="https://ayyaantuu.org/musics/">Musics</a></li> <li id="menu-item-14318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14318"><a href="https://ayyaantuu.org/contact/">Contact</a></li> </ul></div></div></div><div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">
<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div><input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"></div></div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div><input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://ayyaantuu.org/">
<div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap">
<div class="td-header-template-wrap" style="position: relative">
<div class="td-header-mobile-wrap">
<div id="tdi_1_954" class="tdc-zone"><div class="tdc_zone tdi_2_197 wpb_row td-pb-row tdc-element-style">
<style scoped>.tdi_2_197{min-height:0;}.td-header-mobile-wrap{position:relative;width:100%;}
@media(max-width:767px){
.tdi_2_197:before{content:'';display:block;width:100vw;height:100%;position:absolute;left:50%;transform:translateX(-50%);box-shadow:0px 6px 8px 0px rgba(0, 0, 0, 0.08);z-index:20;pointer-events:none;}@media(max-width:767px){
.tdi_2_197:before{width:100%;}
}
}
@media(max-width:767px){
.tdi_2_197{position:relative;}
}</style>
<div class="tdi_1_954_rand_style td-element-style"><style>@media(max-width:767px){
.tdi_1_954_rand_style{background-color:#222222 !important;}
}</style></div><div id="tdi_3_c4f" class="tdc-row"><div class="vc_row tdi_4_843 wpb_row td-pb-row">
<style scoped>.tdi_4_843{min-height:0;}.tdi_4_843,
.tdi_4_843 .tdc-columns{display:block;}.tdi_4_843 .tdc-columns{width:100%;}
@media(max-width:767px){
@media(min-width:768px){
.tdi_4_843{margin-left:-0px;margin-right:-0px;}
.tdi_4_843 .vc_column{padding-left:0px;padding-right:0px;}
}
}</style><div class="vc_column tdi_6_13a wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_6_13a{vertical-align:baseline;}.tdi_6_13a .wpb_wrapper,
.tdi_6_13a .wpb_wrapper .tdc-elements{display:block;}.tdi_6_13a .wpb_wrapper .tdc-elements{width:100%;}.tdi_6_13a .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_6_13a{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_6_13a{width:20% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_7_550 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_7_550">
<style>@media(max-width:767px){
.tdi_7_550{margin-top:2px !important;margin-left:-13px !important;}
}</style>
<style>.tdi_7_550{display:inline-block;}.tdi_7_550 .tdb-mobile-menu-button i{font-size:22px;width:55px;height:55px;line-height:55px;}.tdi_7_550 .tdb-mobile-menu-button{color:#ffffff;}
@media(max-width:767px){
.tdi_7_550 .tdb-mobile-menu-button i{font-size:27px;width:54px;height:54px;line-height:54px;}
}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div></div></div><div class="vc_column tdi_9_f99 wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_9_f99{vertical-align:baseline;}.tdi_9_f99 .wpb_wrapper,
.tdi_9_f99 .wpb_wrapper .tdc-elements{display:block;}.tdi_9_f99 .wpb_wrapper .tdc-elements{width:100%;}.tdi_9_f99 .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_9_f99{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_9_f99{width:60% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_10_8af td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_10_8af">
<style>@media(max-width:767px){
.tdi_10_8af{margin-top:-8px !important;}
}</style>
<style>.tdi_10_8af .tdb-logo-a, .tdi_10_8af h1{flex-direction:row;align-items:center;justify-content:center;}.tdi_10_8af .tdb-logo-svg-wrap{display:block;}.tdi_10_8af .tdb-logo-img-wrap{display:none;}.tdi_10_8af .tdb-logo-text-tagline{margin-top:-3px;margin-left:0;display:block;}.tdi_10_8af .tdb-logo-text-title{display:block;color:#ffffff;}.tdi_10_8af .tdb-logo-text-wrap{flex-direction:column;align-items:center;}.tdi_10_8af .tdb-logo-icon{top:0px;display:block;}
@media(min-width:768px) and (max-width:1018px){
.tdi_10_8af .tdb-logo-img{max-width:186px;}.tdi_10_8af .tdb-logo-text-tagline{margin-top:-2px;margin-left:0;}
}
@media(max-width:767px){
.tdi_10_8af .tdb-logo-svg-wrap + .tdb-logo-img-wrap{display:none;}.tdi_10_8af .tdb-logo-img{max-width:180px;}.tdi_10_8af .tdb-logo-img-wrap{display:block;}
}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://ayyaantuu.org/"><span class="tdb-logo-img-wrap"><img onload="Wpfcll.r(this,true);" src="https://ayyaantuu.org/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" class="tdb-logo-img td-retina-data" data-retina="https://ayyaantuu.org/wp-content/uploads/2015/04/LogoAyyaantuu.png" data-wpfc-original-src="https://ayyaantuu.org/wp-content/uploads/2015/03/LogoAyyaantuu1.png" alt="blank" title="" width="312"/></span></a></div></div></div></div><div class="vc_column tdi_12_959 wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_12_959{vertical-align:baseline;}.tdi_12_959 .wpb_wrapper,
.tdi_12_959 .wpb_wrapper .tdc-elements{display:block;}.tdi_12_959 .wpb_wrapper .tdc-elements{width:100%;}.tdi_12_959 .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_12_959{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_12_959{width:20% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_13_fc6 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_13_fc6">
<style>@media(max-width:767px){
.tdi_13_fc6{margin-right:-18px !important;margin-bottom:0px !important;}
}</style>
<style>.tdi_13_fc6{display:inline-block;float:right;clear:none;}.tdi_13_fc6 .tdb-header-search-button-mob i{font-size:22px;width:55px;height:55px;line-height:55px;}.tdi_13_fc6 .tdb-header-search-button-mob{color:#ffffff;}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-magnifier-big-rounded"></i></a></div></div></div></div></div></div></div></div></div><div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
<div id="tdi_14_bb4" class="tdc-zone"><div class="tdc_zone tdi_15_4d3 wpb_row td-pb-row tdc-element-style" data-sticky-offset="0">
<style scoped>.tdi_15_4d3{min-height:0;}.td-header-mobile-sticky-wrap.td-header-active{opacity:1;}.td-header-mobile-sticky-wrap{-webkit-transition:all 0.3s ease-in-out;-moz-transition:all 0.3s ease-in-out;-o-transition:all 0.3s ease-in-out;transition:all 0.3s ease-in-out;}
@media(max-width:767px){
.tdi_15_4d3:before{content:'';display:block;width:100vw;height:100%;position:absolute;left:50%;transform:translateX(-50%);box-shadow:0px 6px 8px 0px rgba(0, 0, 0, 0.08);z-index:20;pointer-events:none;}.td-header-mobile-sticky-wrap{transform:translateY(-120%);-webkit-transform:translateY(-120%);-moz-transform:translateY(-120%);-ms-transform:translateY(-120%);-o-transform:translateY(-120%);}.td-header-mobile-sticky-wrap.td-header-active{transform:translateY(0);-webkit-transform:translateY(0);-moz-transform:translateY(0);-ms-transform:translateY(0);-o-transform:translateY(0);}@media(max-width:767px){
.tdi_15_4d3:before{width:100%;}
}
}
@media(max-width:767px){
.tdi_15_4d3{position:relative;}
}</style>
<div class="tdi_14_bb4_rand_style td-element-style"><style>@media(max-width:767px){
.tdi_14_bb4_rand_style{background-color:#222222 !important;}
}</style></div><div id="tdi_16_531" class="tdc-row"><div class="vc_row tdi_17_f0f wpb_row td-pb-row">
<style scoped>.tdi_17_f0f{min-height:0;}.tdi_17_f0f,
.tdi_17_f0f .tdc-columns{display:block;}.tdi_17_f0f .tdc-columns{width:100%;}
@media(max-width:767px){
@media(min-width:768px){
.tdi_17_f0f{margin-left:-0px;margin-right:-0px;}
.tdi_17_f0f .vc_column{padding-left:0px;padding-right:0px;}
}
}</style><div class="vc_column tdi_19_47c wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_19_47c{vertical-align:baseline;}.tdi_19_47c .wpb_wrapper,
.tdi_19_47c .wpb_wrapper .tdc-elements{display:block;}.tdi_19_47c .wpb_wrapper .tdc-elements{width:100%;}.tdi_19_47c .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_19_47c{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_19_47c{width:20% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_20_3c1 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_20_3c1">
<style>@media(max-width:767px){
.tdi_20_3c1{margin-top:2px !important;margin-left:-13px !important;}
}</style>
<style>.tdi_20_3c1{display:inline-block;}.tdi_20_3c1 .tdb-mobile-menu-button i{font-size:22px;width:55px;height:55px;line-height:55px;}.tdi_20_3c1 .tdb-mobile-menu-button{color:#ffffff;}
@media(max-width:767px){
.tdi_20_3c1 .tdb-mobile-menu-button i{font-size:27px;width:54px;height:54px;line-height:54px;}
}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div></div></div><div class="vc_column tdi_22_137 wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_22_137{vertical-align:baseline;}.tdi_22_137 .wpb_wrapper,
.tdi_22_137 .wpb_wrapper .tdc-elements{display:block;}.tdi_22_137 .wpb_wrapper .tdc-elements{width:100%;}.tdi_22_137 .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_22_137{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_22_137{width:60% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_23_c51 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_23_c51">
<style>@media(max-width:767px){
.tdi_23_c51{margin-top:-8px !important;}
}</style>
<style>.tdi_23_c51 .tdb-logo-a, .tdi_23_c51 h1{flex-direction:row;align-items:center;justify-content:center;}.tdi_23_c51 .tdb-logo-svg-wrap{display:block;}.tdi_23_c51 .tdb-logo-img-wrap{display:none;}.tdi_23_c51 .tdb-logo-text-tagline{margin-top:-3px;margin-left:0;display:block;}.tdi_23_c51 .tdb-logo-text-title{display:block;color:#ffffff;}.tdi_23_c51 .tdb-logo-text-wrap{flex-direction:column;align-items:center;}.tdi_23_c51 .tdb-logo-icon{top:0px;display:block;}
@media(min-width:768px) and (max-width:1018px){
.tdi_23_c51 .tdb-logo-img{max-width:186px;}.tdi_23_c51 .tdb-logo-text-tagline{margin-top:-2px;margin-left:0;}
}
@media(max-width:767px){
.tdi_23_c51 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{display:none;}.tdi_23_c51 .tdb-logo-img{max-width:180px;}.tdi_23_c51 .tdb-logo-img-wrap{display:block;}
}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://ayyaantuu.org/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://ayyaantuu.org/wp-content/uploads/2015/04/LogoAyyaantuu.png" src="https://ayyaantuu.org/wp-content/uploads/2020/04/202003218c742e17-6349-bd6e-0889-b47f46631df8.png" alt="" title="" width="544"/></span></a></div></div></div></div><div class="vc_column tdi_25_f31 wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>.tdi_25_f31{vertical-align:baseline;}.tdi_25_f31 .wpb_wrapper,
.tdi_25_f31 .wpb_wrapper .tdc-elements{display:block;}.tdi_25_f31 .wpb_wrapper .tdc-elements{width:100%;}.tdi_25_f31 .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_25_f31{vertical-align:middle;}
}
@media(max-width:767px){
.tdi_25_f31{width:20% !important;display:inline-block !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_26_f39 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_26_f39">
<style>@media(max-width:767px){
.tdi_26_f39{margin-right:-18px !important;margin-bottom:0px !important;}
}</style>
<style>.tdi_26_f39{display:inline-block;float:right;clear:none;}.tdi_26_f39 .tdb-header-search-button-mob i{font-size:22px;width:55px;height:55px;line-height:55px;}.tdi_26_f39 .tdb-header-search-button-mob{color:#ffffff;}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-magnifier-big-rounded"></i></a></div></div></div></div></div></div></div></div></div><div class="td-header-desktop-wrap">
<div id="tdi_27_307" class="tdc-zone"><div class="tdc_zone tdi_28_7d0 wpb_row td-pb-row tdc-element-style">
<style scoped>.tdi_28_7d0{min-height:0;}.tdi_28_7d0 > .td-element-style:after{content:'' !important;width:100% !important;height:100% !important;position:absolute !important;top:0 !important;left:0 !important;z-index:0 !important;display:block !important;background-color:#ffffff !important;}.tdi_28_7d0:before{content:'';display:block;width:100vw;height:100%;position:absolute;left:50%;transform:translateX(-50%);box-shadow:0px 6px 8px 0px rgba(0, 0, 0, 0.08);z-index:20;pointer-events:none;}.td-header-desktop-wrap{position:relative;}@media(max-width:767px){
.tdi_28_7d0:before{width:100%;}
}
.tdi_28_7d0{position:relative;}</style>
<div class="tdi_27_307_rand_style td-element-style"><style>.tdi_27_307_rand_style{background-color:#ffffff !important;}</style></div><div id="tdi_29_8ff" class="tdc-row"><div class="vc_row tdi_30_4de wpb_row td-pb-row">
<style scoped>.tdi_30_4de{min-height:0;}.tdi_30_4de,
.tdi_30_4de .tdc-columns{display:block;}.tdi_30_4de .tdc-columns{width:100%;}
.tdi_30_4de{margin-right:1px !important;margin-left:1px !important;}
.tdi_30_4de .td_block_wrap{text-align:left}</style><div class="vc_column tdi_32_530 wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>.tdi_32_530{vertical-align:baseline;}.tdi_32_530 .wpb_wrapper,
.tdi_32_530 .wpb_wrapper .tdc-elements{display:block;}.tdi_32_530 .wpb_wrapper .tdc-elements{width:100%;}.tdi_32_530 .wpb_wrapper{height:auto;}
.tdi_32_530{border-color:#ffffff !important;border-style:solid !important;border-width:0px - 0px - !important;position:relative;}</style>
<div class="tdi_31_e5f_rand_style td-element-style"><style>.tdi_31_e5f_rand_style{background-color:#ffffff !important;}</style></div><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_33_4de tds_menu_active1 tds_menu_sub_active1 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_33_4de" style="z-index: 999;">
<style>.tdi_33_4de{margin-right:-10px !important;margin-left:-30px !important;position:relative;}</style>
<style>.tdi_33_4de .tdb-menu > li .tdb-menu-sep, .tdi_33_4de .tdb-menu-items-dropdown .tdb-menu-sep{top:-1px;}.tdi_33_4de .tdb-menu > li > a .tdb-sub-menu-icon,
.tdi_33_4de .td-subcat-more .tdb-menu-more-subicon{top:-1px;}.tdi_33_4de .td-subcat-more .tdb-menu-more-icon{top:0px;}.tdi_33_4de .tdb-menu > li > a,
.tdi_33_4de .td-subcat-more{color:#ffffff;}.tdi_33_4de .tdb-normal-menu ul .tdb-menu-item > a .tdb-sub-menu-icon{right:0;margin-top:1px;}.tdi_33_4de .tdb-menu .tdb-normal-menu ul,
.tdi_33_4de .td-pulldown-filter-list{box-shadow:1px 1px 4px 0px rgba(0, 0, 0, 0.15);}.tdi_33_4de .tdb-menu .tdb-mega-menu .sub-menu > li{box-shadow:0px 2px 6px 0px rgba(0, 0, 0, 0.1);}</style>
<div class="tdi_33_4de_rand_style td-element-style"><style>.tdi_33_4de_rand_style{background-color:#008e77 !important;}</style></div><style>.tdi_33_4de .tdb-menu > li > a:after, .tdi_33_4de .tdb-menu-items-dropdown .td-subcat-more:after{background-color:;bottom:0px;}</style>
<style></style><div id=tdi_33_4de class="td_block_inner td-fix-index"><ul id="menu-top_menu" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li id="menu-item-826" class="menu-item menu-item-type-post_type menu-item-object-page tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-826"><a href="https://ayyaantuu.org/contact/"><div class="tdb-menu-item-text">Contact</div></a></li>
<li id="menu-item-831" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-831"><a href="https://kichuu.com"><div class="tdb-menu-item-text">Link to Kichuu.com</div></a></li>
</ul></div></div><div class="vc_row_inner tdi_37_bc3 vc_row vc_inner wpb_row td-pb-row tdc-row-content-vert-center">
<style scoped>.tdi_37_bc3{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_37_bc3,
.tdi_37_bc3 .tdc-inner-columns{display:block;}.tdi_37_bc3 .tdc-inner-columns{width:100%;}@media(min-width:768px){
.tdi_37_bc3{margin-left:-0px;margin-right:-0px;}
.tdi_37_bc3 .vc_column_inner{padding-left:0px;padding-right:0px;}
}@media(min-width:767px){
.tdi_37_bc3.tdc-row-content-vert-center, .tdi_37_bc3.tdc-row-content-vert-center .tdc-inner-columns{display:flex;align-items:center;flex:1;}
.tdi_37_bc3.tdc-row-content-vert-bottom, .tdi_37_bc3.tdc-row-content-vert-bottom .tdc-inner-columns{display:flex;align-items:flex-end;flex:1;}
.tdi_37_bc3.tdc-row-content-vert-center .td_block_wrap{vertical-align:middle;}
.tdi_37_bc3.tdc-row-content-vert-bottom .td_block_wrap{vertical-align:bottom;}
}
.tdi_37_bc3{padding-top:28px !important;padding-bottom:9px !important;}
.tdi_37_bc3 .td_block_wrap{text-align:left}
@media(min-width:768px) and (max-width:1018px){
.tdi_37_bc3{margin-bottom:-3px !important;padding-top:9px !important;padding-bottom:0px !important;}
}</style><div class="vc_column_inner tdi_39_483 wpb_column vc_column_container tdc-inner-column td-pb-span4">
<style scoped>.tdi_39_483{vertical-align:baseline;}.tdi_39_483 .wpb_wrapper,
.tdi_39_483 .wpb_wrapper .tdc-elements{display:block;}.tdi_39_483 .wpb_wrapper .tdc-elements{width:100%;}
.tdi_39_483{width:30% !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_39_483{width:24% !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_39_483{width:calc(100% - 468px) !important;}
}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_40_316 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_40_316">
<style>.tdi_40_316 .tdb-logo-a, .tdi_40_316 h1{flex-direction:row;align-items:center;justify-content:center;}.tdi_40_316 .tdb-logo-svg-wrap{display:block;}.tdi_40_316 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{display:none;}.tdi_40_316 .tdb-logo-img{max-width:272px;}.tdi_40_316 .tdb-logo-img-wrap{display:block;}.tdi_40_316 .tdb-logo-text-tagline{margin-top:2px;margin-left:0;display:block;}.tdi_40_316 .tdb-logo-text-title{display:block;}.tdi_40_316 .tdb-logo-text-wrap{flex-direction:column;align-items:flex-start;}.tdi_40_316 .tdb-logo-icon{top:0px;display:block;}
@media(min-width:768px) and (max-width:1018px){
.tdi_40_316 .tdb-logo-img{max-width:220px;}
}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://ayyaantuu.org/"><span class="tdb-logo-img-wrap"><img onload="Wpfcll.r(this,true);" src="https://ayyaantuu.org/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" class="tdb-logo-img td-retina-data" data-retina="https://ayyaantuu.org/wp-content/uploads/2015/04/LogoAyyaantuu.png" data-wpfc-original-src="https://ayyaantuu.org/wp-content/uploads/2015/03/LogoAyyaantuu1.png" alt="blank" title="" width="312"/></span></a></div></div></div></div></div><div class="vc_column_inner tdi_42_511 wpb_column vc_column_container tdc-inner-column td-pb-span8">
<style scoped>.tdi_42_511{vertical-align:baseline;}.tdi_42_511 .wpb_wrapper,
.tdi_42_511 .wpb_wrapper .tdc-elements{display:block;}.tdi_42_511 .wpb_wrapper .tdc-elements{width:100%;}
.tdi_42_511{width:70% !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_42_511{width:76% !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_42_511{width:468px !important;}
}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_43_d20 td_block_template_1">
<style>.tdi_43_d20{margin-bottom:0px !important;}</style>
<style>.tdi_43_d20.td-a-rec{text-align:center;}.tdi_43_d20 .td-element-style{z-index:-1;}.tdi_43_d20.td-a-rec-img{text-align:right;}.tdi_43_d20.td-a-rec-img img{margin:0 0 0 auto;}@media(max-width:767px){
.tdi_43_d20.td-a-rec-img{text-align:center;}
}</style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3737122119"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div><div class="vc_row_inner tdi_45_480 vc_row vc_inner wpb_row td-pb-row">
<style scoped>.tdi_45_480{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_45_480,
.tdi_45_480 .tdc-inner-columns{display:block;}.tdi_45_480 .tdc-inner-columns{width:100%;}</style><div class="vc_column_inner tdi_47_918 wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>.tdi_47_918{vertical-align:baseline;}.tdi_47_918 .wpb_wrapper,
.tdi_47_918 .wpb_wrapper .tdc-elements{display:block;}.tdi_47_918 .wpb_wrapper .tdc-elements{width:100%;}
.tdi_47_918{position:relative;}</style>
<div class="tdi_46_f34_rand_style td-element-style"><style>.tdi_46_f34_rand_style{background-color:#1bb58c !important;}</style></div><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_48_430 tds_menu_active1 tds_menu_sub_active1 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_48_430" style="z-index: 999;">
<style>.tdi_48_430 .tdb-menu > li .tdb-menu-sep, .tdi_48_430 .tdb-menu-items-dropdown .tdb-menu-sep{top:-1px;}.tdi_48_430 .tdb-menu > li > a .tdb-sub-menu-icon,
.tdi_48_430 .td-subcat-more .tdb-menu-more-subicon{top:-1px;}.tdi_48_430 .td-subcat-more .tdb-menu-more-icon{top:0px;}.tdi_48_430 .tdb-menu > li > a,
.tdi_48_430 .td-subcat-more{color:#ffffff;}.tdi_48_430 .tdb-normal-menu ul .tdb-menu-item > a .tdb-sub-menu-icon{right:0;margin-top:1px;}.tdi_48_430 .tdb-menu .tdb-normal-menu ul,
.tdi_48_430 .td-pulldown-filter-list{box-shadow:1px 1px 4px 0px rgba(0, 0, 0, 0.15);}.tdi_48_430 .tdb-menu .tdb-mega-menu .sub-menu > li{box-shadow:0px 2px 6px 0px rgba(0, 0, 0, 0.1);}</style>
<style>.tdi_48_430 .tdb-menu > li > a:after, .tdi_48_430 .tdb-menu-items-dropdown .td-subcat-more:after{background-color:;bottom:0px;}</style>
<style></style><div id=tdi_48_430 class="td_block_inner td-fix-index"><ul id="menu-primary_menu-1" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-812"><a href="http://ayyaantuu.org"><div class="tdb-menu-item-text">Home</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-menu-item-button tdb-menu-item tdb-mega-menu tdb-mega-menu-inactive tdb-mega-menu-first menu-item-745"><a href="https://ayyaantuu.org/category/afaan-oromoo/"><div class="tdb-menu-item-text">Afaan Oromoo</div><i class="tdb-sub-menu-icon td-icon-down"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="tdb-menu-item-text"><div class="tdb_header_mega_menu tdi_49_7f0 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_49_7f0">
<style>.tdi_49_7f0 .block-mega-child-cats:after{border-width:0 1px 0 0;}.tdi_49_7f0 .block-mega-child-cats{text-align:right;}.tdi_49_7f0:not(.td-no-subcats) .td_module_wrap{width:25%;float:left;}.td-md-is-safari .tdi_49_7f0:not(.td-no-subcats) .td_module_wrap{margin-right:-1px;}.tdi_49_7f0.td-no-subcats .td_module_wrap{width:20%;float:left;}.td-md-is-safari .tdi_49_7f0.td-no-subcats .td_module_wrap{margin-right:-1px;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0;padding-bottom:0;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none;}.tdi_49_7f0 .td_module_wrap{padding-left:11px;padding-right:11px;padding-bottom:18px;margin-bottom:18px;display:flex;flex-direction:column;}.tdi_49_7f0 .td_block_inner{margin-left:-11px;margin-right:-11px;display:flex;flex-wrap:wrap;}.tdi_49_7f0 .td-module-container:before{bottom:-18px;border-color:#eaeaea;}.tdi_49_7f0 .td-module-container{border-color:#eaeaea;flex-direction:column;flex:1;flex-basis:auto;}.tdi_49_7f0 .entry-thumb{background-position:center 50%;}.tdi_49_7f0 .td-image-container{display:block;order:0;}.ie10 .tdi_49_7f0 .td-module-meta-info,
.ie11 .tdi_49_7f0 .td-module-meta-info{flex:auto;}.tdi_49_7f0 .td-post-vid-time{display:block;}.tdi_49_7f0 .td-excerpt{column-count:1;column-gap:48px;display:none;}.tdi_49_7f0 .td-audio-player{font-size:12px;opacity:1;visibility:visible;height:auto;}.tdi_49_7f0 .td-module-meta-info{border-color:#eaeaea;}.tdi_49_7f0 .td-post-category{display:inline-block;}.tdi_49_7f0 .td-post-author-name{display:none;}.tdi_49_7f0 .td-post-date,
.tdi_49_7f0 .td-post-author-name span{display:none;}.tdi_49_7f0 .entry-review-stars{display:inline-block;}.tdi_49_7f0 .td-icon-star,
.tdi_49_7f0 .td-icon-star-empty, .tdi_49_7f0 .td-icon-star-half{font-size:15px;}.tdi_49_7f0 .td-module-comments{display:none;}.tdi_49_7f0 .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}html:not([class*='ie']) .tdi_49_7f0 .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_49_7f0 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_49_7f0 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_49_7f0 .td-module-container:before{bottom:-18px;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_49_7f0 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_49_7f0 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_49_7f0 .td-module-container:before{bottom:-18px;}
}
@media(max-width:767px){
.tdi_49_7f0 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_49_7f0 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_49_7f0 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_49_7f0 .td-module-container:before{bottom:-18px;}
}</style><div class="tdb-mega-modules-wrap"><div id=tdi_49_7f0 class="td_block_inner">
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/" rel="bookmark" class="td-image-wrap" title="Oromo Protests Continues &#8211; July 19, 2020"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/nations-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/" rel="bookmark" title="Oromo Protests Continues &#8211; July 19, 2020">Oromo Protests Continues &#8211; July 19, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T08:08:18-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Oromo Protests Continues - July 19, 2020 ﻿ How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/" rel="bookmark" class="td-image-wrap" title="Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/k45-324x394.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/" rel="bookmark" title="Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T22:36:38-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020 Source: Horn of Africa 360 BREAKING NEWS - Anonymous sources said Abiy Ahmed (Abiy...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/" rel="bookmark" class="td-image-wrap" title="Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/abo-kfo-324x256.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/" rel="bookmark" title="Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse">Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T18:17:19-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/#respond">0</a></span> </span></div><div class="td-excerpt">Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse. Mootummaan Dr Abiyyiin durfamu ajjeefamuu artist Hacaaluu Hundeessaan booda Hoggantoota olaanoo jaarmiyaalee...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-global-forum-conference/" rel="bookmark" class="td-image-wrap" title="Oromo Global Forum Conference"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/ogf-324x288.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-global-forum-conference/" rel="bookmark" title="Oromo Global Forum Conference">Oromo Global Forum Conference</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T11:28:46-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-global-forum-conference/#respond">0</a></span> </span></div><div class="td-excerpt">Oromo Global Forum Conference - July 18, 2020 Oromia Global Forum is a global alliance of Oromo Civic, Professional and Faith-Based Organizations and individual proponents...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" class="td-image-wrap" title="Four Oromo youth shot in Washington DC by Neftenya after Protests"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/dcshot-324x400.png"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" title="Four Oromo youth shot in Washington DC by Neftenya after Protests">Four Oromo youth shot in Washington DC by Neftenya after Protests</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T10:53:03-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/#respond">0</a></span> </span></div><div class="td-excerpt">Four Oromo youth shot in Washington DC by Neftenya after Grand Oromo Protests As a DC based organization, we are shocked &amp; highly disappointed...</div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_49_7f0" data-td_block_id="tdi_49_7f0"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_49_7f0" data-td_block_id="tdi_49_7f0"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-menu-item-button tdb-menu-item tdb-mega-menu tdb-mega-menu-inactive menu-item-746"><a href="https://ayyaantuu.org/category/amharic/"><div class="tdb-menu-item-text">Amharic</div><i class="tdb-sub-menu-icon td-icon-down"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="tdb-menu-item-text"><div class="tdb_header_mega_menu tdi_50_c4c td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_50_c4c">
<style>.tdi_50_c4c .block-mega-child-cats:after{border-width:0 1px 0 0;}.tdi_50_c4c .block-mega-child-cats{text-align:right;}.tdi_50_c4c:not(.td-no-subcats) .td_module_wrap{width:25%;float:left;}.td-md-is-safari .tdi_50_c4c:not(.td-no-subcats) .td_module_wrap{margin-right:-1px;}.tdi_50_c4c.td-no-subcats .td_module_wrap{width:20%;float:left;}.td-md-is-safari .tdi_50_c4c.td-no-subcats .td_module_wrap{margin-right:-1px;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5){margin-bottom:0;padding-bottom:0;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none;}.tdi_50_c4c .td_module_wrap{padding-left:11px;padding-right:11px;padding-bottom:18px;margin-bottom:18px;display:flex;flex-direction:column;}.tdi_50_c4c .td_block_inner{margin-left:-11px;margin-right:-11px;display:flex;flex-wrap:wrap;}.tdi_50_c4c .td-module-container:before{bottom:-18px;border-color:#eaeaea;}.tdi_50_c4c .td-module-container{border-color:#eaeaea;flex-direction:column;flex:1;flex-basis:auto;}.tdi_50_c4c .entry-thumb{background-position:center 50%;}.tdi_50_c4c .td-image-container{display:block;order:0;}.ie10 .tdi_50_c4c .td-module-meta-info,
.ie11 .tdi_50_c4c .td-module-meta-info{flex:auto;}.tdi_50_c4c .td-post-vid-time{display:block;}.tdi_50_c4c .td-excerpt{column-count:1;column-gap:48px;display:none;}.tdi_50_c4c .td-audio-player{font-size:12px;opacity:1;visibility:visible;height:auto;}.tdi_50_c4c .td-module-meta-info{border-color:#eaeaea;}.tdi_50_c4c .td-post-category{display:inline-block;}.tdi_50_c4c .td-post-author-name{display:none;}.tdi_50_c4c .td-post-date,
.tdi_50_c4c .td-post-author-name span{display:none;}.tdi_50_c4c .entry-review-stars{display:inline-block;}.tdi_50_c4c .td-icon-star,
.tdi_50_c4c .td-icon-star-empty, .tdi_50_c4c .td-icon-star-half{font-size:15px;}.tdi_50_c4c .td-module-comments{display:none;}.tdi_50_c4c .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}html:not([class*='ie']) .tdi_50_c4c .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_50_c4c .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_50_c4c .td_module_wrap .td-module-container:before{display:block !important;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_50_c4c .td-module-container:before{bottom:-18px;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_50_c4c .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_50_c4c .td_module_wrap .td-module-container:before{display:block !important;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_50_c4c .td-module-container:before{bottom:-18px;}
}
@media(max-width:767px){
.tdi_50_c4c .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_50_c4c .td_module_wrap .td-module-container:before{display:block !important;}.tdi_50_c4c .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_50_c4c .td-module-container:before{bottom:-18px;}
}</style><div class="tdb-mega-modules-wrap"><div id=tdi_50_c4c class="td_block_inner">
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/" rel="bookmark" class="td-image-wrap" title="Oromo Protests Continues &#8211; July 19, 2020"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/nations-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/" rel="bookmark" title="Oromo Protests Continues &#8211; July 19, 2020">Oromo Protests Continues &#8211; July 19, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T08:08:18-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Oromo Protests Continues - July 19, 2020 ﻿ How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/" rel="bookmark" class="td-image-wrap" title="Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/k45-324x394.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/" rel="bookmark" title="Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T22:36:38-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020 Source: Horn of Africa 360 BREAKING NEWS - Anonymous sources said Abiy Ahmed (Abiy...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/harari-community-stands-with-our-community-in-australia/" rel="bookmark" class="td-image-wrap" title="Harari community stands with our community in Australia"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/harari-324x383.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/harari-community-stands-with-our-community-in-australia/" rel="bookmark" title="Harari community stands with our community in Australia">Harari community stands with our community in Australia</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T06:48:21-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/harari-community-stands-with-our-community-in-australia/#respond">0</a></span> </span></div><div class="td-excerpt">Harari community stands with our community in Australia Kun cuunfaa ibsichaa kan Afaan Oromootiin dhiyaatee dha. United Australian Harari Council ibsa gaddaa fi deeggarsaa baasee Hawaasa...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/oduu-voa-afaan-oromo-gaaffiifi-deebii-jaal-marroo/" rel="bookmark" class="td-image-wrap" title="Oduu VOA Afaan Oromo gaaffiifi deebii Jaal Marroo"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2019/03/Maarroo_dirriba-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/oduu-voa-afaan-oromo-gaaffiifi-deebii-jaal-marroo/" rel="bookmark" title="Oduu VOA Afaan Oromo gaaffiifi deebii Jaal Marroo">Oduu VOA Afaan Oromo gaaffiifi deebii Jaal Marroo</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-16T21:47:53-04:00" >July 16, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/oduu-voa-afaan-oromo-gaaffiifi-deebii-jaal-marroo/#respond">0</a></span> </span></div><div class="td-excerpt">Oduu VOA Afaan Oromo gaaffiifi deebii Jaal Marroo, p. 2ffaa</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/amharic/seife-nebelbal-radio-current-oromo-politics-today-rswo/" rel="bookmark" class="td-image-wrap" title="Seife Nebelbal Radio: Current Oromo Politics Today; RSWO"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/oromoflag-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/seife-nebelbal-radio-current-oromo-politics-today-rswo/" rel="bookmark" title="Seife Nebelbal Radio: Current Oromo Politics Today; RSWO">Seife Nebelbal Radio: Current Oromo Politics Today; RSWO</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-10T18:12:49-04:00" >July 10, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/seife-nebelbal-radio-current-oromo-politics-today-rswo/#respond">0</a></span> </span></div><div class="td-excerpt"></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_50_c4c" data-td_block_id="tdi_50_c4c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_50_c4c" data-td_block_id="tdi_50_c4c"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-mega-menu tdb-mega-menu-inactive menu-item-747"><a href="https://ayyaantuu.org/category/english/"><div class="tdb-menu-item-text">English</div><i class="tdb-sub-menu-icon td-icon-down"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="tdb-menu-item-text"><div class="tdb_header_mega_menu tdi_51_444 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_51_444">
<style>.tdi_51_444 .block-mega-child-cats:after{border-width:0 1px 0 0;}.tdi_51_444 .block-mega-child-cats{text-align:right;}.tdi_51_444:not(.td-no-subcats) .td_module_wrap{width:25%;float:left;}.td-md-is-safari .tdi_51_444:not(.td-no-subcats) .td_module_wrap{margin-right:-1px;}.tdi_51_444.td-no-subcats .td_module_wrap{width:20%;float:left;}.td-md-is-safari .tdi_51_444.td-no-subcats .td_module_wrap{margin-right:-1px;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0;padding-bottom:0;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none;}.tdi_51_444 .td_module_wrap{padding-left:11px;padding-right:11px;padding-bottom:18px;margin-bottom:18px;display:flex;flex-direction:column;}.tdi_51_444 .td_block_inner{margin-left:-11px;margin-right:-11px;display:flex;flex-wrap:wrap;}.tdi_51_444 .td-module-container:before{bottom:-18px;border-color:#eaeaea;}.tdi_51_444 .td-module-container{border-color:#eaeaea;flex-direction:column;flex:1;flex-basis:auto;}.tdi_51_444 .entry-thumb{background-position:center 50%;}.tdi_51_444 .td-image-container{display:block;order:0;}.ie10 .tdi_51_444 .td-module-meta-info,
.ie11 .tdi_51_444 .td-module-meta-info{flex:auto;}.tdi_51_444 .td-post-vid-time{display:block;}.tdi_51_444 .td-excerpt{column-count:1;column-gap:48px;display:none;}.tdi_51_444 .td-audio-player{font-size:12px;opacity:1;visibility:visible;height:auto;}.tdi_51_444 .td-module-meta-info{border-color:#eaeaea;}.tdi_51_444 .td-post-category{display:inline-block;}.tdi_51_444 .td-post-author-name{display:none;}.tdi_51_444 .td-post-date,
.tdi_51_444 .td-post-author-name span{display:none;}.tdi_51_444 .entry-review-stars{display:inline-block;}.tdi_51_444 .td-icon-star,
.tdi_51_444 .td-icon-star-empty, .tdi_51_444 .td-icon-star-half{font-size:15px;}.tdi_51_444 .td-module-comments{display:none;}.tdi_51_444 .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}html:not([class*='ie']) .tdi_51_444 .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_51_444 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_51_444 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_51_444 .td-module-container:before{bottom:-18px;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_51_444 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_51_444 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_51_444 .td-module-container:before{bottom:-18px;}
}
@media(max-width:767px){
.tdi_51_444 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_51_444 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_51_444 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_51_444 .td-module-container:before{bottom:-18px;}
}</style><div class="tdb-mega-modules-wrap"><div id=tdi_51_444 class="td_block_inner">
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/" rel="bookmark" class="td-image-wrap" title="Ethiopian Rebel Group Denies Role in Singer’s Death"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/looted1-324x393.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/" rel="bookmark" title="Ethiopian Rebel Group Denies Role in Singer’s Death">Ethiopian Rebel Group Denies Role in Singer’s Death</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T07:48:56-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/#respond">0</a></span> </span></div><div class="td-excerpt">Ethiopian Rebel Group Denies Role in Singer’s Death By Simegnish Yekoye, July 17, 2020 (VOA News) -- While Ethiopia’s government is blaming the insurgent Oromo Liberation...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" class="td-image-wrap" title="Four Oromo youth shot in Washington DC by Neftenya after Protests"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/dcshot-324x400.png"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" title="Four Oromo youth shot in Washington DC by Neftenya after Protests">Four Oromo youth shot in Washington DC by Neftenya after Protests</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T10:53:03-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/#respond">0</a></span> </span></div><div class="td-excerpt">Four Oromo youth shot in Washington DC by Neftenya after Grand Oromo Protests As a DC based organization, we are shocked &amp; highly disappointed...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/abiy-arrives-in-asmara-eritrea/" rel="bookmark" class="td-image-wrap" title="Abiy Arrives in Asmara, Eritrea"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/abiy-in-asmara.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/abiy-arrives-in-asmara-eritrea/" rel="bookmark" title="Abiy Arrives in Asmara, Eritrea">Abiy Arrives in Asmara, Eritrea</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T07:39:17-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/abiy-arrives-in-asmara-eritrea/#respond">0</a></span> </span></div><div class="td-excerpt">Abiy Arrives in Asmara, Eritrea Source: Eritrea Ministry of Information 18 July 2020 - Ethiopia&#039;s Prime Minister, Dr. Abiy Ahmed, arrived in Asmara in mid morning...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/freedom-is-not-free-from-dictatorship-to-democracy/" rel="bookmark" class="td-image-wrap" title="Freedom is not free: From Dictatorship to Democracy"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/abiy-must-g0-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/freedom-is-not-free-from-dictatorship-to-democracy/" rel="bookmark" title="Freedom is not free: From Dictatorship to Democracy">Freedom is not free: From Dictatorship to Democracy</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-17T22:45:51-04:00" >July 17, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/freedom-is-not-free-from-dictatorship-to-democracy/#respond">0</a></span> </span></div><div class="td-excerpt">Freedom is not free: Extraction from “From Dictatorship to Democracy - A Conceptual Framework for Liberation”. Author: Gene Sharp. Jaalataa Nagaroo, July 17, 2020 Several dictatorships,...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/a-killing-in-ethiopia-ignites-a-youth-revolution-in-minnesota/" rel="bookmark" class="td-image-wrap" title="A killing in Ethiopia ignites a youth revolution in Minnesota"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/AishaOromia-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/a-killing-in-ethiopia-ignites-a-youth-revolution-in-minnesota/" rel="bookmark" title="A killing in Ethiopia ignites a youth revolution in Minnesota">A killing in Ethiopia ignites a youth revolution in Minnesota</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-17T21:54:10-04:00" >July 17, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/a-killing-in-ethiopia-ignites-a-youth-revolution-in-minnesota/#respond">0</a></span> </span></div><div class="td-excerpt">‘I want people to know that the Oromo people are here’: A killing in Ethiopia ignites a youth revolution in Minnesota. Young protesters, who call...</div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_51_444" data-td_block_id="tdi_51_444"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_51_444" data-td_block_id="tdi_51_444"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-748"><a href="https://ayyaantuu.org/category/human-rights/"><div class="tdb-menu-item-text">Human Rights</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-mega-menu tdb-mega-menu-inactive menu-item-4069"><a href="http://ayyaantuu.org/category/odaa-post/"><div class="tdb-menu-item-text">Scholars</div><i class="tdb-sub-menu-icon td-icon-down"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="tdb-menu-item-text"><div class="tdb_header_mega_menu tdi_52_f43 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_52_f43">
<style>.tdi_52_f43 .block-mega-child-cats:after{border-width:0 1px 0 0;}.tdi_52_f43 .block-mega-child-cats{text-align:right;}.tdi_52_f43:not(.td-no-subcats) .td_module_wrap{width:25%;float:left;}.td-md-is-safari .tdi_52_f43:not(.td-no-subcats) .td_module_wrap{margin-right:-1px;}.tdi_52_f43.td-no-subcats .td_module_wrap{width:20%;float:left;}.td-md-is-safari .tdi_52_f43.td-no-subcats .td_module_wrap{margin-right:-1px;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0;padding-bottom:0;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none;}.tdi_52_f43 .td_module_wrap{padding-left:11px;padding-right:11px;padding-bottom:18px;margin-bottom:18px;display:flex;flex-direction:column;}.tdi_52_f43 .td_block_inner{margin-left:-11px;margin-right:-11px;display:flex;flex-wrap:wrap;}.tdi_52_f43 .td-module-container:before{bottom:-18px;border-color:#eaeaea;}.tdi_52_f43 .td-module-container{border-color:#eaeaea;flex-direction:column;flex:1;flex-basis:auto;}.tdi_52_f43 .entry-thumb{background-position:center 50%;}.tdi_52_f43 .td-image-container{display:block;order:0;}.ie10 .tdi_52_f43 .td-module-meta-info,
.ie11 .tdi_52_f43 .td-module-meta-info{flex:auto;}.tdi_52_f43 .td-post-vid-time{display:block;}.tdi_52_f43 .td-excerpt{column-count:1;column-gap:48px;display:none;}.tdi_52_f43 .td-audio-player{font-size:12px;opacity:1;visibility:visible;height:auto;}.tdi_52_f43 .td-module-meta-info{border-color:#eaeaea;}.tdi_52_f43 .td-post-category{display:inline-block;}.tdi_52_f43 .td-post-author-name{display:none;}.tdi_52_f43 .td-post-date,
.tdi_52_f43 .td-post-author-name span{display:none;}.tdi_52_f43 .entry-review-stars{display:inline-block;}.tdi_52_f43 .td-icon-star,
.tdi_52_f43 .td-icon-star-empty, .tdi_52_f43 .td-icon-star-half{font-size:15px;}.tdi_52_f43 .td-module-comments{display:none;}.tdi_52_f43 .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}html:not([class*='ie']) .tdi_52_f43 .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_52_f43 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_52_f43 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_52_f43 .td-module-container:before{bottom:-18px;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_52_f43 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_52_f43 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_52_f43 .td-module-container:before{bottom:-18px;}
}
@media(max-width:767px){
.tdi_52_f43 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_52_f43 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_52_f43 .td_module_wrap:nth-last-child(-n+5) .td-module-container:before{display:none !important;}.tdi_52_f43 .td-module-container:before{bottom:-18px;}
}</style><div class="tdb-mega-modules-wrap"><div id=tdi_52_f43 class="td_block_inner">
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/odaa-post/perils-of-negotiating-with-ethiopian-rulers/" rel="bookmark" class="td-image-wrap" title="Perils of Negotiating With Ethiopian Rulers"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2018/11/negotiation-2-640x480-324x400.png"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/odaa-post/perils-of-negotiating-with-ethiopian-rulers/" rel="bookmark" title="Perils of Negotiating With Ethiopian Rulers">Perils of Negotiating With Ethiopian Rulers</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-08T07:23:03-04:00" >July 8, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/odaa-post/perils-of-negotiating-with-ethiopian-rulers/#comments">2</a></span> </span></div><div class="td-excerpt">Perils of Negotiating With Ethiopian Rulers (repost) By Worku Gadissa, November 20, 2018  “Woraabeechi si gatuu mannaa woraabeecha nyaatee lulluqachu woyaa” for mediation and reconciliation....</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/english/vicious-cycle-of-political-conflict-hindered-realization-of-democracy/" rel="bookmark" class="td-image-wrap" title="Vicious cycle of political conflict hindered realization of democracy"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/06/Abiy-IA-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/vicious-cycle-of-political-conflict-hindered-realization-of-democracy/" rel="bookmark" title="Vicious cycle of political conflict hindered realization of democracy">Vicious cycle of political conflict hindered realization of democracy</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-14T17:59:00-04:00" >June 14, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/vicious-cycle-of-political-conflict-hindered-realization-of-democracy/#comments">1</a></span> </span></div><div class="td-excerpt">Vicious cycle of political conflict hindered realization of democracy via development of antagonistic ideologies in Ethiopia (1870 – 2020) By Malkamuu Jaatee, June 14, 2020 Introduction...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/odaa-post/midroc-is-set-to-reopen-we-welcome-business-no-polluter/" rel="bookmark" class="td-image-wrap" title="MIDROC is set to reopen: we welcome business, no polluter"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/06/victim7-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/odaa-post/midroc-is-set-to-reopen-we-welcome-business-no-polluter/" rel="bookmark" title="MIDROC is set to reopen: we welcome business, no polluter">MIDROC is set to reopen: we welcome business, no polluter</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-07T21:04:54-04:00" >June 7, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/odaa-post/midroc-is-set-to-reopen-we-welcome-business-no-polluter/#respond">0</a></span> </span></div><div class="td-excerpt">MIDROC is set to reopen: we welcome business, no polluter By Ibsa A, June 8, 2020 Tom Gardner1 of the New Humanitarian wonderfully exposed the grim...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/odaa-post/ethiopia-in-quagmire-the-regression-of-the-transition/" rel="bookmark" class="td-image-wrap" title="Ethiopia in Quagmire: the regression of the transition"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/06/ethiopia1-324x400.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/odaa-post/ethiopia-in-quagmire-the-regression-of-the-transition/" rel="bookmark" title="Ethiopia in Quagmire: the regression of the transition">Ethiopia in Quagmire: the regression of the transition</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-06T11:03:19-04:00" >June 6, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/odaa-post/ethiopia-in-quagmire-the-regression-of-the-transition/#respond">0</a></span> </span></div><div class="td-excerpt">Ethiopia in Quagmire: the regression of the transition By Buli Edjeta Jobir, June 6 2020 1.      INTRODUCTION Since the declaration of Abiy government’s postponement of the May...</div></div></div></div><div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>                        <div class="td-module-thumb"><a href="https://ayyaantuu.org/odaa-post/urban-layers-of-political-rupture-the-new-politics-of-addis-ababas-megaprojects/" rel="bookmark" class="td-image-wrap" title="Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/06/rjea_a_1774705_f0001_oc-324x400.jpeg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/odaa-post/urban-layers-of-political-rupture-the-new-politics-of-addis-ababas-megaprojects/" rel="bookmark" title="Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects">Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-author-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-05T11:14:57-04:00" >June 5, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/odaa-post/urban-layers-of-political-rupture-the-new-politics-of-addis-ababas-megaprojects/#respond">0</a></span> </span></div><div class="td-excerpt">Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects Biruk Terrefe, Journal of Eastern African Studies, 04 Jun 2020 ABSTRACT From the Derg’s restoration of...</div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_52_f43" data-td_block_id="tdi_52_f43"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_52_f43" data-td_block_id="tdi_52_f43"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-13422"><a href="https://ayyaantuu.org/musics/"><div class="tdb-menu-item-text">Musics</div></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-14318"><a href="https://ayyaantuu.org/contact/"><div class="tdb-menu-item-text">Contact</div></a></li>
</ul></div></div></div></div></div></div><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_56_c73" style="height: 32px"></div><div class="vc_row_inner tdi_58_c4d vc_row vc_inner wpb_row td-pb-row">
<style scoped>.tdi_58_c4d{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_58_c4d,
.tdi_58_c4d .tdc-inner-columns{display:block;}.tdi_58_c4d .tdc-inner-columns{width:100%;}</style><div class="vc_column_inner tdi_60_947 wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>.tdi_60_947{vertical-align:baseline;}.tdi_60_947 .wpb_wrapper,
.tdi_60_947 .wpb_wrapper .tdc-elements{display:block;}.tdi_60_947 .wpb_wrapper .tdc-elements{width:100%;}
.tdi_60_947{border-color:#ffffff !important;border-style:solid !important;border-width:0px 0px 0px 500px !important;}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_search_form tdi_61_753 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_61_753">
<style>.tdi_61_753{border-color:#ffffff !important;border-style:solid !important;border-width:0 !important;}</style>
<style>.td-theme-wrap .tdi_61_753{text-align:left;}.tdi_61_753 .tdb-search-form-input:focus + .tdb-search-form-border + .tdb-search-form-placeholder{top:-0%;transform:translateY(0);}.tdi_61_753 .tdb-search-form-btn i{top:0px;}.tdi_61_753 .tdb-search-msg{margin-top:11px;}</style><div class="tdb-block-inner td-fix-index"><form method="get" class="tdb-search-form" action="https://ayyaantuu.org/"><div role="search" class="tdb-search-form-inner"><input class="tdb-search-form-input" type="text" value="" name="s" /><div class="tdb-search-form-border"></div><button class="wpb_button wpb_btn-inverse tdb-search-form-btn" type="submit"><span>Search</span></div></form></div></div></div></div></div></div></div></div></div></div></div></div></div><div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
<div id="tdi_62_c44" class="tdc-zone"><div class="tdc_zone tdi_63_72f wpb_row td-pb-row tdc-element-style" data-sticky-offset="72">
<style scoped>.tdi_63_72f{min-height:0;}.tdi_63_72f:before{content:'';display:block;width:100vw;height:100%;position:absolute;left:50%;transform:translateX(-50%);box-shadow:0px 6px 8px 0px rgba(0, 0, 0, 0.08);z-index:20;pointer-events:none;}.td-header-desktop-sticky-wrap.td-header-active{opacity:1;transform:translateY(0);-webkit-transform:translateY(0);-moz-transform:translateY(0);-ms-transform:translateY(0);-o-transform:translateY(0);}.td-header-desktop-sticky-wrap{transform:translateY(-120%);-webkit-transform:translateY(-120%);-moz-transform:translateY(-120%);-ms-transform:translateY(-120%);-o-transform:translateY(-120%);-webkit-transition:all 0.3s ease-in-out;-moz-transition:all 0.3s ease-in-out;-o-transition:all 0.3s ease-in-out;transition:all 0.3s ease-in-out;}@media(max-width:767px){
.tdi_63_72f:before{width:100%;}
}
.tdi_63_72f{z-index:999 !important;position:relative;}</style>
<div class="tdi_62_c44_rand_style td-element-style"><style>.tdi_62_c44_rand_style{background-color:rgba(255,255,255,0.95) !important;}</style></div><div id="tdi_64_775" class="tdc-row stretch_row"><div class="vc_row tdi_65_744 wpb_row td-pb-row tdc-row-content-vert-center">
<style scoped>.tdi_65_744{min-height:0;}.tdi_65_744,
.tdi_65_744 .tdc-columns{display:block;}.tdi_65_744 .tdc-columns{width:100%;}@media(min-width:767px){
.tdi_65_744.tdc-row-content-vert-center, .tdi_65_744.tdc-row-content-vert-center .tdc-columns{display:flex;align-items:center;flex:1;}
.tdi_65_744.tdc-row-content-vert-bottom, .tdi_65_744.tdc-row-content-vert-bottom .tdc-columns{display:flex;align-items:flex-end;flex:1;}
.tdi_65_744.tdc-row-content-vert-center .td_block_wrap{vertical-align:middle;}
.tdi_65_744.tdc-row-content-vert-bottom .td_block_wrap{vertical-align:bottom;}
}</style><div class="vc_column tdi_67_f0f wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>.tdi_67_f0f{vertical-align:baseline;}.tdi_67_f0f .wpb_wrapper,
.tdi_67_f0f .wpb_wrapper .tdc-elements{display:block;}.tdi_67_f0f .wpb_wrapper .tdc-elements{width:100%;}.tdi_67_f0f .wpb_wrapper{height:auto;}</style><div class="wpb_wrapper"></div></div></div></div></div></div></div></div><div id="tdb-autoload-article" data-autoload="off" data-autoload-org-post-id="16623" data-autoload-type="" data-autoload-count="5">
<div class="td-main-content-wrap td-container-wrap">
<div class="tdc-content-wrap">
<article id="template-id-14238" class="post-14238 tdb_templates type-tdb_templates status-publish post" itemscope itemtype="https://schema.org/Article">
<div id="tdi_68_50d" class="tdc-zone"><div class="tdc_zone tdi_69_575 wpb_row td-pb-row">
<style scoped>.tdi_69_575{min-height:0;}</style><div id="tdi_70_7ec" class="tdc-row stretch_row_content td-stretch-content"><div class="vc_row tdi_71_f4c wpb_row td-pb-row">
<style scoped>.tdi_71_f4c{min-height:0;}.tdi_71_f4c,
.tdi_71_f4c .tdc-columns{display:block;}.tdi_71_f4c .tdc-columns{width:100%;}</style><div class="vc_column tdi_73_847 wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>.tdi_73_847{vertical-align:baseline;}.tdi_73_847 .wpb_wrapper,
.tdi_73_847 .wpb_wrapper .tdc-elements{display:block;}.tdi_73_847 .wpb_wrapper .tdc-elements{width:100%;}.tdi_73_847 .wpb_wrapper{height:auto;}
.tdi_73_847{padding-top:- !important;border-color:#ffffff !important;border-style:solid !important;border-width:0 !important;position:relative;}</style>
<div class="tdi_72_edd_rand_style td-element-style"><div class="td-element-style-before"><style>.tdi_72_edd_rand_style > .td-element-style-before{content:'' !important;width:100% !important;height:100% !important;position:absolute !important;top:0 !important;left:0 !important;display:block !important;z-index:0 !important;background-repeat:no-repeat !important;background-position:center top !important;}</style></div></div><div class="wpb_wrapper"></div></div></div></div><div id="tdi_74_b4e" class="tdc-row"><div class="vc_row tdi_75_43f wpb_row td-pb-row">
<style scoped>.tdi_75_43f{min-height:0;}.tdi_75_43f,
.tdi_75_43f .tdc-columns{display:block;}.tdi_75_43f .tdc-columns{width:100%;}</style><div class="vc_column tdi_77_454 wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>.tdi_77_454{vertical-align:baseline;}.tdi_77_454 .wpb_wrapper,
.tdi_77_454 .wpb_wrapper .tdc-elements{display:block;}.tdi_77_454 .wpb_wrapper .tdc-elements{width:100%;}.tdi_77_454 .wpb_wrapper{height:auto;}</style><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_78_351 td_block_template_1">
<style>.tdi_78_351.td-a-rec{text-align:center;}.tdi_78_351 .td-element-style{z-index:-1;}</style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3737122119"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div><div id="tdi_79_11c" class="tdc-row"><div class="vc_row tdi_80_751 wpb_row td-pb-row">
<style scoped>.tdi_80_751{min-height:0;}.tdi_80_751,
.tdi_80_751 .tdc-columns{display:block;}.tdi_80_751 .tdc-columns{width:100%;}@media(min-width:768px){
.tdi_80_751{margin-left:-12px;margin-right:-12px;}
.tdi_80_751 .vc_column{padding-left:12px;padding-right:12px;}
}
@media(min-width:1019px) and (max-width:1140px){
@media(min-width:768px){
.tdi_80_751{margin-left:-10px;margin-right:-10px;}
.tdi_80_751 .vc_column{padding-left:10px;padding-right:10px;}
}
}
@media(min-width:768px) and (max-width:1018px){
@media(min-width:768px){
.tdi_80_751{margin-left:-8px;margin-right:-8px;}
.tdi_80_751 .vc_column{padding-left:8px;padding-right:8px;}
}
}
@media(max-width:767px){
@media(min-width:768px){
.tdi_80_751{margin-left:-0px;margin-right:-0px;}
.tdi_80_751 .vc_column{padding-left:0px;padding-right:0px;}
}
}
.tdi_80_751{margin-bottom:60px !important;}
.tdi_80_751 .td_block_wrap{text-align:left}
@media(max-width:767px){
.tdi_80_751{margin-bottom:50px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_80_751{margin-right:6px !important;margin-bottom:40px !important;margin-left:6px !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_80_751{margin-bottom:50px !important;}
}</style><div class="vc_column tdi_82_6e7 wpb_column vc_column_container tdc-column td-pb-span8">
<style scoped>.tdi_82_6e7{vertical-align:baseline;}.tdi_82_6e7 .wpb_wrapper,
.tdi_82_6e7 .wpb_wrapper .tdc-elements{display:block;}.tdi_82_6e7 .wpb_wrapper .tdc-elements{width:100%;}.tdi_82_6e7 .wpb_wrapper{height:auto;}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_post_share tdi_83_34f td-pb-border-top td_block_template_1" data-td-block-uid="tdi_83_34f">
<style>.tdi_83_34f{margin-top:20px !important;margin-bottom:40px !important;}
@media(max-width:767px){
.tdi_83_34f{margin-bottom:30px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_83_34f{margin-bottom:30px !important;}
}</style>
<style>.tdi_83_34f .td-social-expand-tabs-icon, .tdi_83_34f .td-icon-share{color:#1e73be;}.tdi_83_34f .td-social-share-text .td-social-but-text{color:#ffffff;}.tdi_83_34f .td-social-handler .td-social-but-text:before{background-color:#ffffff;}.tdi_83_34f .td-social-share-text,
.tdi_83_34f .td-social-handler{background-color:#50a315;}.tdi_83_34f .td-social-share-text:after{border-color:transparent transparent transparent #50a315;}.tdi_83_34f .td-social-network .td-social-but-icon i{color:#ffffff;}.tdi_83_34f .td-social-network .td-social-but-text{color:#ffffff;}.tdi_83_34f .td-social-network .td-social-but-text:before{background-color:#ffffff;}.tdi_83_34f .td-ps-bg .td-social-network div,
.tdi_83_34f .td-ps-icon-bg .td-social-network .td-social-but-icon, .tdi_83_34f .td-ps-dark-bg .td-social-network div{background-color:#5f8fbf;}.tdi_83_34f .td-ps-icon-arrow .td-social-but-icon:after{border-left-color:#5f8fbf;}.tdi_83_34f .td-ps-border-colored .td-social-but-text{border-color:#5f8fbf;}.tdi_83_34f .td-ps-border .td-social-sharing-button .td-social-but-icon,
.tdi_83_34f .td-ps-border .td-social-sharing-button .td-social-but-text, .tdi_83_34f .td-ps-border .td-social-sharing-button .td-social-handler{border-color:#ededed;}</style><div id="tdi_83_34f" class="td-post-sharing tdb-block td-ps-dark-bg td-ps-padding td-post-sharing-style15"><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Oromo+Protests+Continues+%E2%80%93+July+19%2C+2020&url=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F&via=">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_83_34f">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div></a></div></div></div><div class="td_block_wrap tdb_single_content tdi_84_c5c td-pb-border-top td_block_template_1 td-post-content tagdiv-type" data-td-block-uid="tdi_84_c5c">
<style>.tdi_84_c5c{margin-top:0px !important;}</style>
<style>.tdi_84_c5c, .tdi_84_c5c > p{font-size:14px !important;line-height:1.8 !important;}.tdi_84_c5c h1{font-family:Oswald !important;font-size:24px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c h2{font-family:Oswald !important;font-size:22px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c h3{font-family:Oswald !important;font-size:20px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c h4{font-family:Oswald !important;font-size:18px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c h5{font-family:Oswald !important;font-size:16px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c h6{font-family:Oswald !important;font-size:14px !important;line-height:1 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c li{font-size:14px !important;line-height:1.8 !important;}.tdi_84_c5c li:before{margin-top:1px;line-height:25.2px !important;}.tdi_84_c5c .tdb-block-inner blockquote p{font-family:Oswald !important;font-size:24px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_84_c5c,
.tdi_84_c5c p{color:#444444;}.tdi_84_c5c h1,
.tdi_84_c5c h2, .tdi_84_c5c h3, .tdi_84_c5c h4, .tdi_84_c5c h5, .tdi_84_c5c h6{color:#000000;}
@media(min-width:768px) and (max-width:1018px){
.tdi_84_c5c, .tdi_84_c5c > p{font-size:13px !important;line-height:1.8 !important;}.tdi_84_c5c li{font-size:13px !important;line-height:1.8 !important;}.tdi_84_c5c li:before{margin-top:1px;line-height:23.4px !important;}
}
@media(max-width:767px){
.tdi_84_c5c, .tdi_84_c5c > p{font-size:13px !important;line-height:1.8 !important;}.tdi_84_c5c li{font-size:13px !important;line-height:1.8 !important;}.tdi_84_c5c li:before{margin-top:1px;line-height:23.4px !important;}
}</style><div class="tdb-block-inner td-fix-index"><h2><strong>Oromo Protests Continues &#8211; July 19, 2020</strong></h2> <p><iframe style="border: none; overflow: hidden;" onload="Wpfcll.r(this,true);" data-wpfc-original-src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fmuamin.muhammed%2Fvideos%2F3185342611554790%2F&amp;show_text=0&amp;width=560" width="560" height="315" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span></iframe></p> <p><img onload="Wpfcll.r(this,true);" src="https://ayyaantuu.org/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" class="alignnone size-full wp-image-16629" data-wpfc-original-src="https://ayyaantuu.org/wp-content/uploads/2020/07/nations.jpg" alt="blank" width="640" height="480" data-wpfc-original-srcset="https://ayyaantuu.org/wp-content/uploads/2020/07/nations.jpg 640w, https://ayyaantuu.org/wp-content/uploads/2020/07/nations-300x225.jpg 300w, https://ayyaantuu.org/wp-content/uploads/2020/07/nations-150x113.jpg 150w, https://ayyaantuu.org/wp-content/uploads/2020/07/nations-560x420.jpg 560w, https://ayyaantuu.org/wp-content/uploads/2020/07/nations-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2020/07/nations-265x198.jpg 265w" sizes="(max-width: 640px) 100vw, 640px"/></p> <hr /> <p>How Oromo pedestrians are treated on the streets of Finfinne? This video is an example<br /> <iframe style="border: none; overflow: hidden;" onload="Wpfcll.r(this,true);" data-wpfc-original-src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fmideksa.abishu.9%2Fvideos%2F3312458462312147%2F&amp;show_text=0&amp;width=560" width="560" height="495" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p> <hr /> <p><iframe style="border: none; overflow: hidden;" onload="Wpfcll.r(this,true);" data-wpfc-original-src="https://www.facebook.com/plugins/post.php?href=https%3A%2F%2Fwww.facebook.com%2Fayyaantuu.oromiyaa%2Fposts%2F3192402654174201&amp;width=500" width="500" height="611" frameborder="0" scrolling="no"></iframe><br /> <iframe style="border: none; overflow: hidden;" onload="Wpfcll.r(this,true);" data-wpfc-original-src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Foromo.land%2Fvideos%2F3300379150052017%2F&amp;show_text=0&amp;width=560" width="560" height="315" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p> <hr /> <p>Source: <span class="fwn fcg"><span class="fwb fcg" data-ft="{&quot;tn&quot;:&quot;;&quot;}"><a id="js_wf" href="https://www.facebook.com/hunde.biyyaa?__tn__=%2CdC-R-R&amp;eid=ARB0HGVLuLHPNBF4tvb7-U_vAmSFOdHsH8oJppIG_milf6kEl2M3sIuaidRyiCmVsP2qJsbnDKCZPNsw&amp;hc_ref=ARSRIeAgNrMrN1LyAYzfRZi8Ebryangtw13aWBs_2bVRFcEAcK7pUhKBVtybU5RqSDk&amp;fref=nf" data-hovercard="/ajax/hovercard/user.php?id=100003850137321&amp;extragetparams=%7B%22__tn__%22%3A%22%2CdC-R-R%22%2C%22eid%22%3A%22ARB0HGVLuLHPNBF4tvb7-U_vAmSFOdHsH8oJppIG_milf6kEl2M3sIuaidRyiCmVsP2qJsbnDKCZPNsw%22%2C%22hc_ref%22%3A%22ARSRIeAgNrMrN1LyAYzfRZi8Ebryangtw13aWBs_2bVRFcEAcK7pUhKBVtybU5RqSDk%22%2C%22fref%22%3A%22nf%22%7D" data-hovercard-prefer-more-content-show="1" data-hovercard-referer="ARSRIeAgNrMrN1LyAYzfRZi8Ebryangtw13aWBs_2bVRFcEAcK7pUhKBVtybU5RqSDk" aria-describedby="u_30_1" aria-owns="js_wb">Irbuu Shinniiggaa</a></span></span></p> <p>Abiy Haamad sirna abbaa irrummaa Itoophiyaa irratti diriirsuuf irriba dhaba. Kanaaf sagal Asmaraatti deddeebi´a. Moodeela sirna abbaa irrummaa Asmaraa jiru Shaggaritti fidee hojiirra oolchuuf dhama´a. Waan namni kun hubachuu dadhabe tokko itti himna. Moodeelli abbaa irrummaa Isaayaas Afawarqii kan Asmaraatti hojjete Itoophiyaa irratti, keessattuu Oromiyaatti gonkumaa hin hojjetu. Sababa isaa ibsuun ni danda´ama.</p> <p>Isaayaas maaluu yoo tahe qabsoo ummata Eertiraa sirna Nafxanyaa jalaa bilisa baasuuf godhame hogganee injifatee aangoo qabate. Kanaafuu hangamuu abbaa irree gara jabeessa tahullee, kaleessa qabsoo waggaa 30 keessatti tarree duraarra dhaabatee lolee lolchiisee Eertiraanota sirna Nafxanyaa jalaa baase. Kanaaf jecha lammiin biyyattii hangamuu yoo isa morme keessoo isaatti garuu Isaayaasiin ni kabajaan. Sana qofa miti. Ummanni Eertiraa lakkoofsaan xiqqoo dha. Humna waraanaa fi polisaa heddumminaan leenjisuun ummata kana ukkaamsuun ulfaataa hin tahu.</p> <p>Gama Itoophiyaatti yoo deebine garuu seenaan jiru guutuutti kan Eertiraa irraa adda. Abiy OPDO dha. OPDO jechuun ammoo seenaa qabsoo Oromoo keessatti maqaa badduu dha. Wayyaanee jalatti guddatee ummata keenya fixaa fi ficcisiisaa as gahe. Seenaa qabsoo Oromoo keessatti gahee diinummaa malee gahee firoomaa hin qabu. Gurmuun isaa kan silaa seeratti dhihaatee adabamutu masaraa seene. Ummanni Oromoo nama Abiy jedhamu maqaa eega dhagahee reefuu waggaa 2 yookiin 3. Injifannoo qabsoo Oromootiin argame saamee aangoo ittiin qabate. Onnee ummata Oromoo keessatti diinummaadhaan beekama. Har´a ammoo caalaatti diinummaa isaa hammeessee agarsiisaa jira. Hayyuu Oromoon jaalattuu fi jala yaatu guuree hidhaatti naqeera. kaanis ajjeeseera.</p> <p>Namni akkasii abbaa irree tahee humna qawweetiin saba guddaa kanarra bubbuluu hin danda´u. Yeroodhaaf nama ajjeesuu, hidhuu, ukkaamsuu fi hiraarsuu ni danda´a taha. Garaaf bultoota Afaan Oromoo dubbattu hagoo qabatee ittiin Oromoo burjaajessuu kajeela taha. Akka Isaayaasittin Itoophiyaa dhiitee bulcha jedhee hawwuus ni mala. Afaaniin tokkummaa Itoophiyaa lallabaan Oromoo fi Amaara gidduutti ibidda qabsiiseen Amaara qabadhee Oromoo dhaha jedhee fiigaas jira. Kun garuu fagoo hin deemu. Oromiyaa keessatti Oromoo qofa osoo hin taane dachiin Oromiyaa illee isa tufteetti. Umriin isaa gabaabduu dha. Gorsi inni Isaayaas irraa fudhatee Oromoo irratti raaw´achuuf fiffiigaa jiru kan umrii aangoo isaa dheeressu osoo hin taane kan gabaabsuu dha.</p></div></div><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_85_c57 td_block_template_1">
<style>.tdi_85_c57.td-a-rec{text-align:center;}.tdi_85_c57 .td-element-style{z-index:-1;}</style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="4534715383"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div class="td_block_wrap tdb_single_post_share tdi_87_093 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_87_093">
<style>.tdi_87_093{margin-top:20px !important;margin-bottom:40px !important;}
@media(max-width:767px){
.tdi_87_093{margin-bottom:30px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_87_093{margin-bottom:30px !important;}
}</style>
<style>.tdi_87_093 .td-social-expand-tabs-icon, .tdi_87_093 .td-icon-share{color:#1e73be;}.tdi_87_093 .td-social-share-text .td-social-but-text{color:#ffffff;}.tdi_87_093 .td-social-handler .td-social-but-text:before{background-color:#ffffff;}.tdi_87_093 .td-social-share-text,
.tdi_87_093 .td-social-handler{background-color:#50a315;}.tdi_87_093 .td-social-share-text:after{border-color:transparent transparent transparent #50a315;}.tdi_87_093 .td-social-network .td-social-but-icon i{color:#ffffff;}.tdi_87_093 .td-social-network .td-social-but-text{color:#ffffff;}.tdi_87_093 .td-social-network .td-social-but-text:before{background-color:#ffffff;}.tdi_87_093 .td-ps-bg .td-social-network div,
.tdi_87_093 .td-ps-icon-bg .td-social-network .td-social-but-icon, .tdi_87_093 .td-ps-dark-bg .td-social-network div{background-color:#5f8fbf;}.tdi_87_093 .td-ps-icon-arrow .td-social-but-icon:after{border-left-color:#5f8fbf;}.tdi_87_093 .td-ps-border-colored .td-social-but-text{border-color:#5f8fbf;}.tdi_87_093 .td-ps-border .td-social-sharing-button .td-social-but-icon,
.tdi_87_093 .td-ps-border .td-social-sharing-button .td-social-but-text, .tdi_87_093 .td-ps-border .td-social-sharing-button .td-social-handler{border-color:#ededed;}</style><div id="tdi_87_093" class="td-post-sharing tdb-block td-ps-dark-bg td-ps-padding td-post-sharing-style15"><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Oromo+Protests+Continues+%E2%80%93+July+19%2C+2020&url=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F&via=">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_87_093">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div></a></div></div></div><div class="td_block_wrap tdb_single_next_prev tdi_88_c58 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_88_c58">
<style>@media(min-width:1019px) and (max-width:1140px){
.tdi_88_c58{margin-bottom:30px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_88_c58{margin-bottom:20px !important;}
}</style>
<style>.tdi_88_c58 .tdb-next-post a{color:#426b00;font-family:Open Sans !important;font-size:18px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_88_c58 .tdb-next-post:hover a{color:#999999;}.tdi_88_c58 .tdb-next-post span{color:#aaaaaa;font-family:Open Sans !important;font-size:12px !important;line-height:1 !important;font-weight:500 !important;text-transform:capitalize !important;letter-spacing:1px !important;}
@media(min-width:1019px) and (max-width:1140px){}
@media(min-width:768px) and (max-width:1018px){
.tdi_88_c58 .tdb-next-post a{font-family:Open Sans !important;font-size:14px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_88_c58 .tdb-next-post span{font-family:Open Sans !important;font-size:12px !important;line-height:1 !important;font-weight:500 !important;text-transform:capitalize !important;letter-spacing:0px !important;}
}
@media(max-width:767px){
.tdi_88_c58 .tdb-next-post a{font-family:Open Sans !important;font-size:14px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}
}</style><div class="tdb-block-inner td-fix-index"><div class="tdb-next-post tdb-next-post-bg tdb-post-prev"><span>Previous article</span><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/">Ethiopian Rebel Group Denies Role in Singer’s Death</a></div></div></div><div class="td_block_wrap tdb_single_related tdi_89_9c7 td_with_ajax_pagination td-pb-border-top td_block_template_1 tdb-single-related-posts" data-td-block-uid="tdi_89_9c7">
<style>.td-theme-wrap .tdi_89_9c7 .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_89_9c7 .td-subcat-item a:hover, .td-theme-wrap .tdi_89_9c7 .td-subcat-item .td-cur-simple-item{color:#8224e3;}
.td-theme-wrap .tdi_89_9c7 .block-title > *,
.td-theme-wrap .tdi_89_9c7 .td-subcat-dropdown:hover .td-subcat-more{background-color:#8224e3;}
.td-theme-wrap .td-footer-wrapper .tdi_89_9c7 .block-title > *{padding:6px 7px 5px;line-height:1;}
.td-theme-wrap .tdi_89_9c7 .block-title{border-color:#8224e3;}
.td-theme-wrap .tdi_89_9c7 .block-title > *{color:#1e73be;}
.td-theme-wrap .tdi_89_9c7 .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_89_9c7 .td_quote_on_blocks, .td-theme-wrap .tdi_89_9c7 .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_89_9c7 .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_89_9c7 .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_89_9c7 .td-instagram-user a{color:#8224e3;}
.td-theme-wrap .tdi_89_9c7 .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_89_9c7 .td-load-more-wrap a:hover{background-color:#8224e3;border-color:#8224e3;}
.td-theme-wrap .tdi_89_9c7 .td-read-more a, .td-theme-wrap .tdi_89_9c7 .td-weather-information:before, .td-theme-wrap .tdi_89_9c7 .td-weather-week:before, .td-theme-wrap .tdi_89_9c7 .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_89_9c7 .td-post-category, .td-theme-wrap .tdi_89_9c7 .td-post-category:hover{background-color:#8224e3;}
.tdi_89_9c7{margin-bottom:50px !important;}
@media(max-width:767px){
.tdi_89_9c7{margin-bottom:24px !important;}
}</style>
<style>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</style><div id=tdi_89_9c7 class="td_block_inner tdb-block-inner td-fix-index">
<div class="tdb_module_related td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" class="td-image-wrap" title="Four Oromo youth shot in Washington DC by Neftenya after Protests"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/dcshot-218x150.png"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/" rel="bookmark" title="Four Oromo youth shot in Washington DC by Neftenya after Protests">Four Oromo youth shot in Washington DC by Neftenya after Protests</a></h3>
<div class="td-editor-date"> <a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T10:53:03-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/#respond">0</a></span> </span></div><div class="td-excerpt">Four Oromo youth shot in Washington DC by Neftenya after Grand Oromo Protests As a DC based organization, we are shocked &amp; highly disappointed...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/english/four-oromo-youth-shot-in-washington-dc-by-neftenya-after-protests/">Read more</a></div></div></div></div><div class="tdb_module_related td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/hiriira-mormii-munich-germany-adoolessa-18-2020/" rel="bookmark" class="td-image-wrap" title="Hiriira Mormii Munich, Germany &#8211; Adoolessa 18, 2020"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/munchine-218x150.jpg"></span></a></div></div><div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/hiriira-mormii-munich-germany-adoolessa-18-2020/" rel="bookmark" title="Hiriira Mormii Munich, Germany &#8211; Adoolessa 18, 2020">Hiriira Mormii Munich, Germany &#8211; Adoolessa 18, 2020</a></h3>
<div class="td-editor-date"> <a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T07:26:47-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/hiriira-mormii-munich-germany-adoolessa-18-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Hiriira Mormii Munich, Germany - Adoolessa 18, 2020</div><div class="td-read-more"> <a href="https://ayyaantuu.org/afaan-oromoo/hiriira-mormii-munich-germany-adoolessa-18-2020/">Read more</a></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_89_9c7" data-td_block_id="tdi_89_9c7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_89_9c7" data-td_block_id="tdi_89_9c7"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="tdm_block td_block_wrap tdm_block_column_title tdi_90_1c1 tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_90_1c1">
<style>.tdi_90_1c1{margin-bottom:0px !important;}</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>.tdi_91_4c2 .tdm-title{color:#f24000;font-family:Oswald !important;font-size:20px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}body .tdi_90_1c1:hover .tdi_91_4c2 .tdm-title{color:#000000;-webkit-text-fill-color:unset;background:transparent;transition:none;}.tdi_90_1c1:hover .tdi_91_4c2 .tdm-title{cursor:default;}body .tdi_91_4c2 .tdm-title-line:after{background:#000000;}.tdi_90_1c1:hover .tdi_91_4c2 .tdm-title-line:after{background:#000000;}.tdi_91_4c2 .tdm-title-line{width:165px;height:30px;}.tdi_91_4c2 .tdm-title-line:after{height:3px;bottom:40%;}
@media(min-width:768px) and (max-width:1018px){
.tdi_91_4c2 .tdm-title-line{width:150px;}.tdi_91_4c2 .tdm-title{font-family:Oswald !important;font-size:18px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}
}</style><div class="tds-title tds-title2 td-fix-index tdi_91_4c2"><h3 class="tdm-title tdm-title-md">Similar Articles</h3><div class="tdm-title-line"></div></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_column_title tdi_92_44f tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_92_44f">
<style>.tdi_92_44f{margin-bottom:0px !important;}
@media(max-width:767px){
.tdi_92_44f{margin-bottom:10px !important;}
}</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>.tdi_93_444 .tdm-title{color:#000000;font-family:Oswald !important;font-size:20px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}body .tdi_92_44f:hover .tdi_93_444 .tdm-title{color:#000000;-webkit-text-fill-color:unset;background:transparent;transition:none;}.tdi_92_44f:hover .tdi_93_444 .tdm-title{cursor:default;}body .tdi_93_444 .tdm-title-line:after{background:#000000;}.tdi_92_44f:hover .tdi_93_444 .tdm-title-line:after{background:#000000;}.tdi_93_444 .tdm-title-line{width:98px;height:30px;}.tdi_93_444 .tdm-title-line:after{height:3px;bottom:40%;}
@media(min-width:768px) and (max-width:1018px){
.tdi_93_444 .tdm-title-line{width:90px;}.tdi_93_444 .tdm-title{font-family:Oswald !important;font-size:18px !important;line-height:1.4 !important;font-weight:700 !important;text-transform:capitalize !important;letter-spacing:1px !important;}
}</style><div class="tds-title tds-title2 td-fix-index tdi_93_444"><h3 class="tdm-title tdm-title-md">Comments</h3><div class="tdm-title-line"></div></div></div></div></div><div class="td_block_wrap tdb_single_comments tdi_94_533 tdb-comm-layout2 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_94_533">
<style>.tdi_94_533 .comment-link{display:none;}.tdi_94_533 .comment{border-bottom-style:dashed;}.tdi_94_533 .comment .children{border-top-style:dashed;}.tdi_94_533 .comment-form .submit{background-color:#000000;font-family:Oswald !important;font-size:13px !important;line-height:1 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_94_533 .comment-form .submit:hover{background-color:#444444;}.tdi_94_533 cite{font-family:Oswald !important;font-size:14px !important;line-height:1 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_94_533 .comment-content p{font-size:13px !important;}.tdi_94_533 .comment-reply-link{text-transform:capitalize !important;}.tdi_94_533 .comment-reply-title{font-family:Oswald !important;font-size:16px !important;line-height:1.6 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:1px !important;}.tdi_94_533 input[type=text],
.tdi_94_533 textarea{font-size:13px !important;}.tdi_94_533 .comment-form-cookies-consent label,
.tdi_94_533 .logged-in-as, .tdi_94_533 .logged-in-as a{font-size:13px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_94_533 cite{font-family:Oswald !important;font-size:14px !important;line-height:1 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:0px !important;}.tdi_94_533 .comment-content p{font-size:12px !important;}.tdi_94_533 .comment-reply-title{font-family:Oswald !important;font-size:14px !important;line-height:1.6 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:0px !important;}.tdi_94_533 input[type=text],
.tdi_94_533 textarea{font-size:12px !important;}.tdi_94_533 .comment-form .submit{font-family:Oswald !important;font-size:12px !important;line-height:1 !important;font-weight:600 !important;text-transform:capitalize !important;letter-spacing:0px !important;}.tdi_94_533 .comment-form-cookies-consent label,
.tdi_94_533 .logged-in-as, .tdi_94_533 .logged-in-as a{font-size:12px !important;}
}
@media(max-width:767px){
.tdi_94_533 .comment-link, .tdi_94_533 .comment-edit-link{font-size:11px !important;}
}</style><div class="tdb-block-inner td-fix-index"><div class="comments" id="comments">	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/afaan-oromoo/oromo-protests-continues-july-19-2020/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://ayyaantuu.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div><div class="comment-form-input-wrap td-form-comment">
<textarea 
placeholder="Comment:" 
id="comment" 
name="comment" 
cols="45" 
rows="8" 
aria-required="true"
></textarea>
<div class="td-warning-comment">Please enter your comment!</div></div><div class="comment-form-input-wrap td-form-author">
<input 
class="" 
id="author" 
name="author" 
placeholder="Name:*" 
type="text" 
value="" 
size="30"  aria-required='true' 
/>
<div class="td-warning-author">Please enter your name here</div></div><div class="comment-form-input-wrap td-form-email">
<input 
class="" 
id="email" 
name="email" 
placeholder="Email:*" 
type="text" 
value="" 
size="30"  aria-required='true' 
/>
<div class="td-warning-email-error">You have entered an incorrect email address!</div><div class="td-warning-email">Please enter your email address here</div></div><div class="comment-form-input-wrap td-form-url"> <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></div><p class="comment-form-cookies-consent">
<input 
id="wp-comment-cookies-consent" 
name="wp-comment-cookies-consent" 
type="checkbox" 
value="yes"
/>
<label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label>
</p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='16623' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9595158aac" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="51"/></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div></div><div class="td_block_wrap tdb_single_post_share tdi_95_111 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_95_111">
<style>.tdi_95_111{margin-top:20px !important;margin-bottom:40px !important;}
@media(max-width:767px){
.tdi_95_111{margin-bottom:30px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_95_111{margin-bottom:30px !important;}
}</style>
<style>.tdi_95_111 .td-social-expand-tabs-icon, .tdi_95_111 .td-icon-share{color:#1e73be;}.tdi_95_111 .td-social-share-text .td-social-but-text{color:#ffffff;}.tdi_95_111 .td-social-handler .td-social-but-text:before{background-color:#ffffff;}.tdi_95_111 .td-social-share-text,
.tdi_95_111 .td-social-handler{background-color:#50a315;}.tdi_95_111 .td-social-share-text:after{border-color:transparent transparent transparent #50a315;}.tdi_95_111 .td-social-network .td-social-but-icon i{color:#ffffff;}.tdi_95_111 .td-social-network .td-social-but-text{color:#ffffff;}.tdi_95_111 .td-social-network .td-social-but-text:before{background-color:#ffffff;}.tdi_95_111 .td-ps-bg .td-social-network div,
.tdi_95_111 .td-ps-icon-bg .td-social-network .td-social-but-icon, .tdi_95_111 .td-ps-dark-bg .td-social-network div{background-color:#5f8fbf;}.tdi_95_111 .td-ps-icon-arrow .td-social-but-icon:after{border-left-color:#5f8fbf;}.tdi_95_111 .td-ps-border-colored .td-social-but-text{border-color:#5f8fbf;}.tdi_95_111 .td-ps-border .td-social-sharing-button .td-social-but-icon,
.tdi_95_111 .td-ps-border .td-social-sharing-button .td-social-but-text, .tdi_95_111 .td-ps-border .td-social-sharing-button .td-social-handler{border-color:#ededed;}</style><div id="tdi_95_111" class="td-post-sharing tdb-block td-ps-dark-bg td-ps-padding td-post-sharing-style15"><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Oromo+Protests+Continues+%E2%80%93+July+19%2C+2020&url=https%3A%2F%2Fayyaantuu.org%2Fafaan-oromoo%2Foromo-protests-continues-july-19-2020%2F&via=">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_95_111">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div></a></div></div></div></div></div><div class="vc_column tdi_97_555 wpb_column vc_column_container tdc-column td-pb-span4 td-is-sticky">
<style scoped>.tdi_97_555{vertical-align:baseline;}.tdi_97_555 .wpb_wrapper,
.tdi_97_555 .wpb_wrapper .tdc-elements{display:block;}.tdi_97_555 .wpb_wrapper .tdc-elements{width:100%;}.tdi_97_555 .wpb_wrapper{height:auto;}</style><div class="wpb_wrapper"><div class="vc_row_inner tdi_99_36e vc_row vc_inner wpb_row td-pb-row">
<style scoped>.tdi_99_36e{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_99_36e,
.tdi_99_36e .tdc-inner-columns{display:block;}.tdi_99_36e .tdc-inner-columns{width:100%;}
.tdi_99_36e{margin-right:0px !important;margin-left:0px !important;position:relative;}
.tdi_99_36e .td_block_wrap{text-align:left}
@media(max-width:767px){
.tdi_99_36e{padding-top:20px !important;}
}</style>
<div class="tdi_98_515_rand_style td-element-style"><div class="td-element-style-before"><style>.tdi_98_515_rand_style > .td-element-style-before{content:'' !important;width:100% !important;height:100% !important;position:absolute !important;top:0 !important;left:0 !important;display:block !important;z-index:0 !important;background-image:url("https://ayyaantuu.org/wp-content/uploads/2020/04/deggarsa.jpg") !important;background-size:cover !important;background-position:center top !important;}</style></div><style>.tdi_98_515_rand_style{background-color:#ededed !important;}</style></div><div class="vc_column_inner tdi_101_c5b wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>.tdi_101_c5b{vertical-align:top;}.tdi_101_c5b .wpb_wrapper,
.tdi_101_c5b .wpb_wrapper .tdc-elements{display:block;}.tdi_101_c5b .wpb_wrapper .tdc-elements{width:100%;}
.tdi_101_c5b{border-color:#ffffff !important;border-style:solid !important;border-width:0 !important;}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_inline_image tdi_102_c64 tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_102_c64">
<style>.tdi_102_c64 .tdm-inline-image-wrap:hover:before{opacity:0;}</style><div class="tdm-inline-image-wrap"><img alt="blank" onload="Wpfcll.r(this,true);" src="https://ayyaantuu.org/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" class="tdm-image td-fix-index" data-wpfc-original-src="https://ayyaantuu.org/wp-content/uploads/2020/06/deggarsa2.jpg" title="deggarsa2"></div></div></div></div></div></div><div class="vc_row_inner tdi_104_331 vc_row vc_inner wpb_row td-pb-row">
<style scoped>.tdi_104_331{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_104_331,
.tdi_104_331 .tdc-inner-columns{display:block;}.tdi_104_331 .tdc-inner-columns{width:100%;}
.tdi_104_331{margin-right:0px !important;margin-left:0px !important;position:relative;}
.tdi_104_331 .td_block_wrap{text-align:left}
@media(max-width:767px){
.tdi_104_331{padding-top:20px !important;}
}</style>
<div class="tdi_103_5fe_rand_style td-element-style"><style>.tdi_103_5fe_rand_style{background-color:#ededed !important;}</style></div><div class="vc_column_inner tdi_106_f75 wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>.tdi_106_f75{vertical-align:baseline;}.tdi_106_f75 .wpb_wrapper,
.tdi_106_f75 .wpb_wrapper .tdc-elements{display:block;}.tdi_106_f75 .wpb_wrapper .tdc-elements{width:100%;}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_flex_block_5 tdi_107_735 td-pb-border-top td_block_template_1 td_flex_block" data-td-block-uid="tdi_107_735">
<style>.td-theme-wrap .tdi_107_735 .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_107_735 .td-subcat-item a:hover, .td-theme-wrap .tdi_107_735 .td-subcat-item .td-cur-simple-item{color:#088200;}
.td-theme-wrap .tdi_107_735 .block-title > *,
.td-theme-wrap .tdi_107_735 .td-subcat-dropdown:hover .td-subcat-more{background-color:#088200;}
.td-theme-wrap .td-footer-wrapper .tdi_107_735 .block-title > *{padding:6px 7px 5px;line-height:1;}
.td-theme-wrap .tdi_107_735 .block-title{border-color:#088200;}
.td-theme-wrap .tdi_107_735 .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_107_735 .td_quote_on_blocks, .td-theme-wrap .tdi_107_735 .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_107_735 .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_107_735 .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_107_735 .td-instagram-user a{color:#088200;}
.td-theme-wrap .tdi_107_735 .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_107_735 .td-load-more-wrap a:hover{background-color:#088200;border-color:#088200;}
.td-theme-wrap .tdi_107_735 .td-read-more a, .td-theme-wrap .tdi_107_735 .td-weather-information:before, .td-theme-wrap .tdi_107_735 .td-weather-week:before, .td-theme-wrap .tdi_107_735 .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_107_735 .td-post-category, .td-theme-wrap .tdi_107_735 .td-post-category:hover{background-color:#088200;}</style>
<style>.tdi_107_735 .td_module_wrap{width:100%;float:left;padding-left:20px;padding-right:20px;padding-bottom:18px;margin-bottom:18px;display:flex;}.tdi_107_735 .td_module_wrap:nth-last-child(1){margin-bottom:0;padding-bottom:0;}.tdi_107_735 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none;}.tdi_107_735 .td_block_inner{margin-left:-20px;margin-right:-20px;display:flex;flex-wrap:wrap;}.tdi_107_735 .td-module-container:before{bottom:-18px;border-color:#eaeaea;}.tdi_107_735 .td-module-container{border-color:#eaeaea;flex-grow:1;}.tdi_107_735 .entry-thumb{background-position:center 50%;}.tdi_107_735 .td-post-vid-time{display:block;}.tdi_107_735 .td-module-meta-info{border-color:#eaeaea;}.tdi_107_735 .td-excerpt{display:block;}.tdi_107_735 .td-audio-player{opacity:1;visibility:visible;height:auto;font-size:13px;}.tdi_107_735 .td-post-category{display:inline-block;}.tdi_107_735 .td-post-author-name{display:inline-block;}.tdi_107_735 .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}.tdi_107_735 .td-post-date,
.tdi_107_735 .td-post-author-name span{display:inline-block;}.tdi_107_735 .entry-review-stars{display:inline-block;}.tdi_107_735 .td-icon-star,
.tdi_107_735 .td-icon-star-empty, .tdi_107_735 .td-icon-star-half{font-size:15px;}.tdi_107_735 .td-module-comments{display:block;}.tdi_107_735 .td-read-more{display:block;}.tdi_107_735 .td-image-container{flex:0 0 0;}html:not([class*='ie']) .tdi_107_735 .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_107_735 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_107_735 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_107_735 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_107_735 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}.tdi_107_735 .td-module-container:before{bottom:-18px;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_107_735 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_107_735 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_107_735 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_107_735 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}.tdi_107_735 .td-module-container:before{bottom:-18px;}
}
@media(max-width:767px){
.tdi_107_735 .td_module_wrap{padding-bottom:18px !important;margin-bottom:18px !important;padding-bottom:18px;margin-bottom:18px;}.tdi_107_735 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_107_735 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_107_735 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}.tdi_107_735 .td-module-container:before{bottom:-18px;}
}</style><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">MOST POPULAR</span></h4><div class="td-pulldown-syle-default td-subcat-filter" id="td_pulldown_tdi_107_735"><ul class="td-subcat-list" id="td_pulldown_tdi_107_735_list"><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_108_e05" data-td_filter_value="" data-td_block_id="tdi_107_735" href="#">All</a></li><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_109_324" data-td_filter_value="2" data-td_block_id="tdi_107_735" href="#">Afaan Oromoo</a></li><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_110_c54" data-td_filter_value="3" data-td_block_id="tdi_107_735" href="#">Amharic</a></li><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_111_3a3" data-td_filter_value="4" data-td_block_id="tdi_107_735" href="#">English</a></li><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_112_2a3" data-td_filter_value="5" data-td_block_id="tdi_107_735" href="#">Human Rights</a></li><li class="td-subcat-item"><a class="td-subcat-link" id="tdi_113_59f" data-td_filter_value="14" data-td_block_id="tdi_107_735" href="#">Odaa Post</a></li></ul><div class="td-subcat-dropdown"><div class="td-subcat-more" aria-haspopup="true"><span>More</span><i class="td-icon-read-down"></i></div><ul class="td-pulldown-filter-list"></ul></div></div></div><div id=tdi_107_735 class="td_block_inner td-mc1-wrap">
<div class="td_module_flex td_module_flex_5 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a><div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/" rel="bookmark" class="td-image-wrap" title="New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2019/09/the-hijacked-revolution.jpg"></span></a></div></div><div class="td-module-meta-info td-module-meta-info-bottom">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/" rel="bookmark" title="New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf">New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf</a></h3><div class="td-editor-date"><span class="td-author-date"><span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-09-03T23:16:23-04:00" >September 4, 2019</time></span><span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/#comments">4</a></span></span></div><div class="td-excerpt">Book: የተጠለፈ ትግል (The hijacked revolution) in PDF Via Aba Orma, September 3, 2019 የተጠለፈ ትግል (The hijacked revolution) Author: Mudhin Siraj Pages: 152 Language: Amharic Year: July 2019 To...</div><div class="td-read-more"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/">Read more</a></div></div></div></div><div class="td_module_flex td_module_flex_5 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/amharic/" class="td-post-category">Amharic</a><div class="td-module-thumb"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/" rel="bookmark" class="td-image-wrap" title="PM Abiy Ahmed says African Americans live in the past"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/06/abiyahmedq-696x392.jpg"></span></a></div></div><div class="td-module-meta-info td-module-meta-info-bottom">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/" rel="bookmark" title="PM Abiy Ahmed says African Americans live in the past">PM Abiy Ahmed says African Americans live in the past</a></h3><div class="td-editor-date"><span class="td-author-date"><span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-07T14:52:04-04:00" >June 7, 2020</time></span><span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/#comments">9</a></span></span></div><div class="td-excerpt">PM Abiy Ahmed says African Americans live in the past In the first part of this video, Ethiopia’s Prime Minister Abiy Ahmed Ali (Nobel Peace...</div><div class="td-read-more"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/">Read more</a></div></div></div></div><div class="td_module_flex td_module_flex_5 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a><div class="td-module-thumb"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/" rel="bookmark" class="td-image-wrap" title="Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/JustinDrapeauCanadien-696x364.jpg"></span></a></div></div><div class="td-module-meta-info td-module-meta-info-bottom">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/" rel="bookmark" title="Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed">Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed</a></h3><div class="td-editor-date"><span class="td-author-date"><span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-12T13:08:15-04:00" >July 12, 2020</time></span><span class="td-module-comments"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/#comments">3</a></span></span></div><div class="td-excerpt">Ethnic cleansing continued in Oromia Regional State by Ethiopian government lead by Dr. Abiy Ahmed, Prime Minister of Ethiopia July 10, 2020 The Right Honourable Justin...</div><div class="td-read-more"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/">Read more</a></div></div></div></div><div class="td_module_flex td_module_flex_5 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a><div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/breaking-news-mass-murder-in-ambo/" rel="bookmark" class="td-image-wrap" title="Breaking news: mass murder in Ambo"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/mass-murder.jpg"></span></a></div></div><div class="td-module-meta-info td-module-meta-info-bottom">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/breaking-news-mass-murder-in-ambo/" rel="bookmark" title="Breaking news: mass murder in Ambo">Breaking news: mass murder in Ambo</a></h3><div class="td-editor-date"><span class="td-author-date"><span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-02T21:26:52-04:00" >July 2, 2020</time></span><span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/breaking-news-mass-murder-in-ambo/#comments">3</a></span></span></div><div class="td-excerpt">Disturbing picture from Ambo where Hachalu was buried today. Unknown number of unarmed youth were assassinated by Abiy soldiers today. July 2, 2020 Via Qaanqee...</div><div class="td-read-more"><a href="https://ayyaantuu.org/afaan-oromoo/breaking-news-mass-murder-in-ambo/">Read more</a></div></div></div></div><div class="td_module_flex td_module_flex_5 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a><div class="td-module-thumb"><a href="https://ayyaantuu.org/english/the-oromo-demand-the-removal-of-statues-of-menelik-ii/" rel="bookmark" class="td-image-wrap" title="The Oromo Demand: The Removal of Statues of Menelik II"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/minik-ii-696x408.jpg"></span></a></div></div><div class="td-module-meta-info td-module-meta-info-bottom">
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/the-oromo-demand-the-removal-of-statues-of-menelik-ii/" rel="bookmark" title="The Oromo Demand: The Removal of Statues of Menelik II">The Oromo Demand: The Removal of Statues of Menelik II</a></h3><div class="td-editor-date"><span class="td-author-date"><span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-05T08:46:05-04:00" >July 5, 2020</time></span><span class="td-module-comments"><a href="https://ayyaantuu.org/english/the-oromo-demand-the-removal-of-statues-of-menelik-ii/#respond">0</a></span></span></div><div class="td-excerpt">The Oromo Demand: The Removal of Statues of Menelik II By Leenjiso Horo, July 5, 2020 Today in the United States of America, the statues of...</div><div class="td-read-more"><a href="https://ayyaantuu.org/english/the-oromo-demand-the-removal-of-statues-of-menelik-ii/">Read more</a></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div><div class="ayyaa-after-content" id="ayyaa-641933251"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px;" 
data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="3737122119"></ins> 
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Admin"></span><meta itemprop="datePublished" content="2020-07-19T08:08:18-04:00"><meta itemprop="dateModified" content="2020-07-19T08:08:18-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://ayyaantuu.org/wp-content/uploads/2015/03/LogoAyyaantuu1.png"></span><meta itemprop="name" content="Admin"></span><meta itemprop="headline" content="Oromo Protests Continues - July 19, 2020"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://ayyaantuu.org/wp-content/uploads/2020/07/nations.jpg"><meta itemprop="width" content="640"><meta itemprop="height" content="480"></span>                </article></div></div></div><div class="td-footer-template-wrap" style="position: relative">
<div class="td-footer-wrap">
<div id="tdi_114_5c5" class="tdc-zone"><div class="tdc_zone tdi_115_b01 wpb_row td-pb-row tdc-element-style">
<style scoped>.tdi_115_b01{min-height:0;}.tdi_115_b01 > .td-element-style:after{content:'' !important;width:100% !important;height:100% !important;position:absolute !important;top:0 !important;left:0 !important;z-index:0 !important;display:block !important;background-color:#000000 !important;}</style>
<div class="tdi_114_5c5_rand_style td-element-style"></div><div id="tdi_116_571" class="tdc-row stretch_row_1200 td-stretch-content"><div class="vc_row tdi_117_715 wpb_row td-pb-row tdc-element-style">
<style scoped>.tdi_117_715{min-height:0;}.tdi_117_715,
.tdi_117_715 .tdc-columns{display:block;}.tdi_117_715 .tdc-columns{width:100%;}
@media(min-width:768px) and (max-width:1018px){
@media(min-width:768px){
.tdi_117_715{margin-left:-10px;margin-right:-10px;}
.tdi_117_715 .vc_column{padding-left:10px;padding-right:10px;}
}
}
.tdi_117_715{padding-top:60px !important;padding-bottom:50px !important;position:relative;}
.tdi_117_715 .td_block_wrap{text-align:left}
@media(min-width:768px) and (max-width:1018px){
.tdi_117_715{padding-top:30px !important;padding-bottom:30px !important;}
}
@media(max-width:767px){
.tdi_117_715{padding-top:40px !important;padding-bottom:40px !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_117_715{padding-top:50px !important;padding-bottom:40px !important;}
}</style>
<div class="tdi_116_571_rand_style td-element-style"><div class="td-element-style-before"><style>.tdi_116_571_rand_style > .td-element-style-before{content:'' !important;width:100% !important;height:100% !important;position:absolute !important;top:0 !important;left:0 !important;display:block !important;z-index:0 !important;background-image:url("http://www.ayyaantuu.org/wp-content/uploads/2020/04/2020030241be963d-bf23-f538-02c7-62e8c04555b5-1.jpg") !important;background-position:center center !important;opacity:0.24 !important;background-size:cover !important;}</style></div></div><div class="vc_column tdi_119_545 wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>.tdi_119_545{vertical-align:baseline;}.tdi_119_545 .wpb_wrapper,
.tdi_119_545 .wpb_wrapper .tdc-elements{display:block;}.tdi_119_545 .wpb_wrapper .tdc-elements{width:100%;}.tdi_119_545 .wpb_wrapper{height:auto;}
@media(max-width:767px){
.tdi_119_545{margin-bottom:40px !important;justify-content:center !important;text-align:center !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_119_545{width:25% !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_119_545{width:25% !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_120_331 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_120_331">
<style>.tdi_120_331 .tdb-logo-a, .tdi_120_331 h1{flex-direction:row;align-items:center;justify-content:flex-start;}.tdi_120_331 .tdb-logo-svg-wrap{display:block;}.tdi_120_331 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{display:none;}.tdi_120_331 .tdb-logo-img-wrap{display:block;}.tdi_120_331 .tdb-logo-text-tagline{margin-top:2px;margin-left:0;display:block;}.tdi_120_331 .tdb-logo-text-title{display:block;}.tdi_120_331 .tdb-logo-text-wrap{flex-direction:column;align-items:flex-start;}.tdi_120_331 .tdb-logo-icon{top:0px;display:block;}</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://ayyaantuu.org/"><span class="tdb-logo-img-wrap"><img onload="Wpfcll.r(this,true);" src="https://ayyaantuu.org/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" class="tdb-logo-img td-retina-data" data-retina="https://ayyaantuu.org/wp-content/uploads/2015/04/LogoAyyaantuu.png" data-wpfc-original-src="https://ayyaantuu.org/wp-content/uploads/2015/03/LogoAyyaantuu1.png" alt="blank" title="" width="312"/></span></a></div></div><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_121_f73 tdm-inline-block tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_121_f73">
<style>.tdi_121_f73{margin-bottom:25px !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_121_f73{margin-bottom:20px !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_121_f73{margin-bottom:15px !important;}
}</style>
<style>.tdi_121_f73 .tdm-descr{color:#ffffff;font-family:Poppins !important;font-size:13px !important;line-height:1.6 !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_121_f73 .tdm-descr{font-family:Poppins !important;font-size:11px !important;line-height:1.6 !important;}
}</style><p class="tdm-descr">© Ayyaantuu 2020.  Disclaimer: All views expressed on this site are opinion of authors and ayyaantuu is not responsible for the content.</p></div><div class="tdm_block td_block_wrap tdm_block_socials tdi_122_528 tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_122_528">
<style>.tdi_123_57c .tdm-social-item i{font-size:14px;vertical-align:middle;line-height:25.2px;}.tdi_123_57c .tdm-social-item i.td-icon-twitter,
.tdi_123_57c .tdm-social-item i.td-icon-linkedin, .tdi_123_57c .tdm-social-item i.td-icon-pinterest, .tdi_123_57c .tdm-social-item i.td-icon-blogger, .tdi_123_57c .tdm-social-item i.td-icon-vimeo{font-size:11.2px;}.tdi_123_57c .tdm-social-item{width:25.2px;height:25.2px;margin:5px 10px 5px 0;}.tdi_123_57c .tdm-social-item-wrap:last-child .tdm-social-item{margin-right:0 !important;}.tdi_123_57c .tdm-social-item i,
.tds-team-member2 .tdi_123_57c.tds-social1 .tdm-social-item i{color:#ffffff;}.tdi_123_57c .tdm-social-item-wrap:hover i,
.tds-team-member2 .tdi_123_57c.tds-social1 .tdm-social-item:hover i{color:#dd3333;}.tdi_123_57c .tdm-social-text{display:none;margin-left:2px;margin-right:18px;}
@media(min-width:768px) and (max-width:1018px){
.tdi_123_57c .tdm-social-item i{font-size:12px;vertical-align:middle;line-height:21.6px;}.tdi_123_57c .tdm-social-item i.td-icon-twitter,
.tdi_123_57c .tdm-social-item i.td-icon-linkedin, .tdi_123_57c .tdm-social-item i.td-icon-pinterest, .tdi_123_57c .tdm-social-item i.td-icon-blogger, .tdi_123_57c .tdm-social-item i.td-icon-vimeo{font-size:9.6px;}.tdi_123_57c .tdm-social-item{width:21.6px;height:21.6px;}
}</style><div class="tdm-social-wrapper tds-social1 tdi_123_57c"><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="#" class="tdm-social-text">Facebook</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="#" class="tdm-social-text">Twitter</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-youtube"></i></a><a href="#" class="tdm-social-text">Youtube</a></div></div></div></div></div><div class="vc_column tdi_125_554 wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>.tdi_125_554{vertical-align:baseline;}.tdi_125_554 .wpb_wrapper,
.tdi_125_554 .wpb_wrapper .tdc-elements{display:block;}.tdi_125_554 .wpb_wrapper .tdc-elements{width:100%;}.tdi_125_554 .wpb_wrapper{height:auto;}
.tdi_125_554{padding-right:40px !important;padding-left:60px !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_125_554{padding-right:20px !important;padding-left:30px !important;width:45% !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_125_554{padding-right:0px !important;padding-left:10px !important;width:47% !important;}
}
@media(max-width:767px){
.tdi_125_554{padding-right:0px !important;padding-left:0px !important;}
}</style><div class="wpb_wrapper"><div class="vc_row_inner tdi_127_3c1 vc_row vc_inner wpb_row td-pb-row">
<style scoped>.tdi_127_3c1{position:relative !important;top:0;transform:none;-webkit-transform:none;}.tdi_127_3c1,
.tdi_127_3c1 .tdc-inner-columns{display:block;}.tdi_127_3c1 .tdc-inner-columns{width:100%;}@media(min-width:768px){
.tdi_127_3c1{margin-left:-10px;margin-right:-10px;}
.tdi_127_3c1 .vc_column_inner{padding-left:10px;padding-right:10px;}
}
@media(min-width:768px) and (max-width:1018px){
@media(min-width:768px){
.tdi_127_3c1{margin-left:-5px;margin-right:-5px;}
.tdi_127_3c1 .vc_column_inner{padding-left:5px;padding-right:5px;}
}
}</style><div class="vc_column_inner tdi_129_ff1 wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>.tdi_129_ff1{vertical-align:baseline;}.tdi_129_ff1 .wpb_wrapper,
.tdi_129_ff1 .wpb_wrapper .tdc-elements{display:block;}.tdi_129_ff1 .wpb_wrapper .tdc-elements{width:100%;}
.tdi_129_ff1{width:40% !important;}
@media(max-width:767px){
.tdi_129_ff1{margin-bottom:40px !important;width:100% !important;}
}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_130_c3c td-pb-border-top td_block_template_2 td-fix-index" data-td-block-uid="tdi_130_c3c">
<style>.td-theme-wrap .tdi_130_c3c .td-block-title > *,
.td-theme-wrap .tdi_130_c3c .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_130_c3c .td-subcat-item a:hover, .td-theme-wrap .tdi_130_c3c .td-subcat-item .td-cur-simple-item, .td-theme-wrap .tdi_130_c3c .td-subcat-dropdown:hover .td-subcat-more span, .td-theme-wrap .tdi_130_c3c .td-subcat-dropdown:hover .td-subcat-more i{color:#ffffff;}
.td-theme-wrap .tdi_130_c3c .td-subcat-dropdown ul:after{background-color:#ffffff;}
.td-theme-wrap .tdi_130_c3c .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_130_c3c .td_quote_on_blocks, .td-theme-wrap .tdi_130_c3c .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_130_c3c .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_130_c3c .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_130_c3c .td-instagram-user a{color:#ffffff;}
.td-theme-wrap .tdi_130_c3c .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_130_c3c .td-load-more-wrap a:hover{background-color:#ffffff;border-color:#ffffff;}
.td-theme-wrap .tdi_130_c3c .td-read-more a, .td-theme-wrap .tdi_130_c3c .td-weather-information:before, .td-theme-wrap .tdi_130_c3c .td-weather-week:before, .td-theme-wrap .tdi_130_c3c .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_130_c3c .td-post-category, .td-theme-wrap .tdi_130_c3c .td-post-category:hover{background-color:#ffffff;}
.tdi_130_c3c{margin-bottom:20px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_130_c3c{margin-bottom:-5px !important;}
}
@media(max-width:767px){
.tdi_130_c3c{margin-bottom:0px !important;display:inline-block !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_130_c3c{margin-bottom:0px !important;}
}</style>
<style>.tdi_130_c3c .td-block-title a, .tdi_130_c3c .td-block-title span{font-family:Volkhov !important;font-size:20px !important;font-weight:400 !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_130_c3c .td-block-title a, .tdi_130_c3c .td-block-title span{font-family:Volkhov !important;font-size:19px !important;font-weight:400 !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_130_c3c .td-block-title a, .tdi_130_c3c .td-block-title span{font-family:Volkhov !important;font-size:18px !important;font-weight:400 !important;}
}</style><h4 class="td-block-title"><span class="td-pulldown-size">Quick Links</span></h4></div><div class="td_block_wrap td_block_list_menu tdi_131_7cd td-pb-border-top td_block_template_1 widget" data-td-block-uid="tdi_131_7cd">
<style>.tdi_131_7cd{margin-bottom:0px !important;}</style>
<style>.tdi_131_7cd ul{margin:0px;text-align:left;justify-content:flex-start;}.tdi_131_7cd a{color:#ffffff;}.tdi_131_7cd a:hover{color:#dd3333;}.tdi_131_7cd li{font-family:Poppins !important;font-size:13px !important;text-transform:uppercase !important;letter-spacing:1px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_131_7cd ul li{margin-bottom:0px;}.tdi_131_7cd ul li:last-child{margin-bottom:0;}.tdi_131_7cd li{font-family:Poppins !important;font-size:11px !important;text-transform:uppercase !important;letter-spacing:1px !important;}
}</style><div class="td-block-title-wrap"></div><div id=tdi_131_7cd class="td_block_inner td-fix-index"><div class="menu-primary_menu-container"><ul id="menu-primary_menu-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-812"><a href="http://ayyaantuu.org">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-745"><a href="https://ayyaantuu.org/category/afaan-oromoo/">Afaan Oromoo</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-746"><a href="https://ayyaantuu.org/category/amharic/">Amharic</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-747"><a href="https://ayyaantuu.org/category/english/">English</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://ayyaantuu.org/category/human-rights/">Human Rights</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4069"><a href="http://ayyaantuu.org/category/odaa-post/">Scholars</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13422"><a href="https://ayyaantuu.org/musics/">Musics</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14318"><a href="https://ayyaantuu.org/contact/">Contact</a></li> </ul></div></div></div></div></div></div><div class="vc_column_inner tdi_133_74f wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>.tdi_133_74f{vertical-align:baseline;}.tdi_133_74f .wpb_wrapper,
.tdi_133_74f .wpb_wrapper .tdc-elements{display:block;}.tdi_133_74f .wpb_wrapper .tdc-elements{width:100%;}
.tdi_133_74f{width:60% !important;}
@media(max-width:767px){
.tdi_133_74f{margin-bottom:40px !important;width:100% !important;justify-content:center !important;text-align:center !important;}
}</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_134_673 td-pb-border-top td_block_template_2 td-fix-index" data-td-block-uid="tdi_134_673">
<style>.td-theme-wrap .tdi_134_673 .td-block-title > *,
.td-theme-wrap .tdi_134_673 .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_134_673 .td-subcat-item a:hover, .td-theme-wrap .tdi_134_673 .td-subcat-item .td-cur-simple-item, .td-theme-wrap .tdi_134_673 .td-subcat-dropdown:hover .td-subcat-more span, .td-theme-wrap .tdi_134_673 .td-subcat-dropdown:hover .td-subcat-more i{color:#ffffff;}
.td-theme-wrap .tdi_134_673 .td-subcat-dropdown ul:after{background-color:#ffffff;}
.td-theme-wrap .tdi_134_673 .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_134_673 .td_quote_on_blocks, .td-theme-wrap .tdi_134_673 .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_134_673 .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_134_673 .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_134_673 .td-instagram-user a{color:#ffffff;}
.td-theme-wrap .tdi_134_673 .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_134_673 .td-load-more-wrap a:hover{background-color:#ffffff;border-color:#ffffff;}
.td-theme-wrap .tdi_134_673 .td-read-more a, .td-theme-wrap .tdi_134_673 .td-weather-information:before, .td-theme-wrap .tdi_134_673 .td-weather-week:before, .td-theme-wrap .tdi_134_673 .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_134_673 .td-post-category, .td-theme-wrap .tdi_134_673 .td-post-category:hover{background-color:#ffffff;}
.tdi_134_673{margin-bottom:20px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_134_673{margin-bottom:-5px !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_134_673{margin-bottom:0px !important;}
}</style>
<style>.tdi_134_673 .td-block-title a, .tdi_134_673 .td-block-title span{font-family:Volkhov !important;font-size:20px !important;font-weight:400 !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_134_673 .td-block-title a, .tdi_134_673 .td-block-title span{font-family:Volkhov !important;font-size:19px !important;font-weight:400 !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_134_673 .td-block-title a, .tdi_134_673 .td-block-title span{font-family:Volkhov !important;font-size:18px !important;font-weight:400 !important;}
}</style><h4 class="td-block-title"><span class="td-pulldown-size">Must Read</span></h4></div><div class="td_block_wrap td_flex_block_1 tdi_135_535 td-pb-border-top td_block_template_1 td_ajax_preloading_preload td_flex_block" data-td-block-uid="tdi_135_535">
<style>.tdi_135_535{margin-bottom:0px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_135_535{margin-top:-5px !important;}
}</style>
<style>.tdi_135_535 .entry-thumb{background-position:center 50%;background-image:none !important;}.tdi_135_535 .td-image-container{display:none;margin-left:0;margin-right:auto;}.tdi_135_535 .td-module-meta-info{padding:0px;border-color:#eaeaea;}.tdi_135_535 .td_module_wrap{padding-left:0px;padding-right:0px;padding-bottom:8px;margin-bottom:8px;}.tdi_135_535 .td_block_inner{margin-left:-0px;margin-right:-0px;}.tdi_135_535 .td-module-container:before{bottom:-8px;}.tdi_135_535 .td-module-container{padding:0px;}.tdi_135_535 .td-post-vid-time{display:block;}.tdi_135_535 .td-post-category{padding:0px;display:none;color:#ffffff;}.tdi_135_535 .td-author-photo .avatar{width:20px;height:20px;margin-right:6px;border-radius:50%;}.tdi_135_535 .td-excerpt{display:none;column-count:1;column-gap:48px;}.tdi_135_535 .td-audio-player{opacity:1;visibility:visible;height:auto;font-size:13px;}.tdi_135_535 .td-read-more{display:none;}.tdi_135_535 .td-author-date{display:none;}.tdi_135_535 .td-post-author-name{display:none;}.tdi_135_535 .td-post-date,
.tdi_135_535 .td-post-author-name span{display:none;color:#e3382b;}.tdi_135_535 .entry-review-stars{display:none;}.tdi_135_535 .td-icon-star,
.tdi_135_535 .td-icon-star-empty, .tdi_135_535 .td-icon-star-half{font-size:15px;}.tdi_135_535 .td-module-comments{display:none;}.tdi_135_535 .td_module_wrap:nth-last-child(1){margin-bottom:0;padding-bottom:0;}.tdi_135_535 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none;}.tdi_135_535 .td-post-category:hover{color:#ffffff;}.tdi_135_535 .td-module-title a{color:#ffffff;}.tdi_135_535 .td_module_wrap:hover .td-module-title a{color:#dd3333 !important;}.tdi_135_535 .td-post-author-name a{color:#000000;}.tdi_135_535 .td-module-meta-info,
.tdi_135_535 .td-next-prev-wrap{text-align:left;}.tdi_135_535 .td-category-pos-above .td-post-category{align-self:flex-start !important;}.tdi_135_535 .td-category-pos-image .td-post-category{left:0;right:auto;transform:translateX(0);-webkit-transform:translateX(0);}.tdi_135_535 .td-ajax-next-page{margin-right:auto;margin-left:0;}.tdi_135_535 .entry-title{margin:0px;font-family:Volkhov !important;font-size:14px !important;line-height:1.4 !important;}.tdi_135_535 .td-editor-date,
.tdi_135_535 .td-editor-date .td-post-author-name, .tdi_135_535 .td-module-comments a{font-family:Poppins !important;font-size:13px !important;line-height:1 !important;font-weight:500 !important;text-transform:uppercase !important;letter-spacing:0.5px !important;}html:not([class*='ie']) .tdi_135_535 .td-module-container:hover .entry-thumb:before{opacity:0;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_135_535 .td-image-container{display:none;}.tdi_135_535 .td_module_wrap{padding-bottom:6px;margin-bottom:6px;padding-bottom:6px !important;margin-bottom:6px !important;}.tdi_135_535 .td-module-container:before{bottom:-6px;}.tdi_135_535 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_135_535 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_135_535 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}.tdi_135_535 .td-read-more{margin:0px;}.tdi_135_535 .entry-title{font-family:Volkhov !important;font-size:13px !important;line-height:1.4 !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_135_535 .td-image-container{display:none;}.tdi_135_535 .td_module_wrap{padding-bottom:5px;margin-bottom:5px;padding-bottom:5px !important;margin-bottom:5px !important;}.tdi_135_535 .td-module-container:before{bottom:-5px;}.tdi_135_535 .td-post-category{padding:5px 7px 4px;}.tdi_135_535 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_135_535 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_135_535 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}.tdi_135_535 .td-read-more a{padding:8px 16px 6px;}.tdi_135_535 .entry-title{font-family:Volkhov !important;font-size:12px !important;line-height:1.4 !important;}.tdi_135_535 .td-editor-date,
.tdi_135_535 .td-editor-date .td-post-author-name, .tdi_135_535 .td-module-comments a{font-family:Poppins !important;font-size:10px !important;line-height:1 !important;font-weight:500 !important;text-transform:uppercase !important;letter-spacing:0.5px !important;}
}
@media(max-width:767px){
.tdi_135_535 .td-image-container{display:none;}.tdi_135_535 .td_module_wrap{padding-bottom:8px;margin-bottom:8px;padding-bottom:8px !important;margin-bottom:8px !important;}.tdi_135_535 .td-module-container:before{bottom:-8px;}.tdi_135_535 .td_module_wrap:nth-last-child(1){margin-bottom:0 !important;padding-bottom:0 !important;}.tdi_135_535 .td_module_wrap .td-module-container:before{display:block !important;}.tdi_135_535 .td_module_wrap:nth-last-child(1) .td-module-container:before{display:none !important;}
}</style><div class="td-block-title-wrap"></div><div id=tdi_135_535 class="td_block_inner td-mc1-wrap">
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/" rel="bookmark" title="Oromo Protests Continues &#8211; July 19, 2020">Oromo Protests Continues &#8211; July 19, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T08:08:18-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Oromo Protests Continues - July 19, 2020 ﻿ How Oromo pedestrians are treated on the streets of Finfinne? This video is an example Source: Irbuu Shinniiggaa Abiy Haamad sirna...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/afaan-oromoo/oromo-protests-continues-july-19-2020/">View Post</a></div></div></div></div><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/" rel="bookmark" title="Ethiopian Rebel Group Denies Role in Singer’s Death">Ethiopian Rebel Group Denies Role in Singer’s Death</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T07:48:56-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/#respond">0</a></span> </span></div><div class="td-excerpt">Ethiopian Rebel Group Denies Role in Singer’s Death By Simegnish Yekoye, July 17, 2020 (VOA News) -- While Ethiopia’s government is blaming the insurgent Oromo Liberation...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/">View Post</a></div></div></div></div><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/" rel="bookmark" title="Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T22:36:38-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/#respond">0</a></span> </span></div><div class="td-excerpt">Analysis of Amhara and Oromo Protests in DC on Jul 17, 2020 Source: Horn of Africa 360 BREAKING NEWS - Anonymous sources said Abiy Ahmed (Abiy...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/amharic/analysis-of-amhara-and-oromo-protests-in-dc-on-jul-17-2020/">View Post</a></div></div></div></div><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/" rel="bookmark" title="Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse">Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-18T18:17:19-04:00" >July 18, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/#respond">0</a></span> </span></div><div class="td-excerpt">Mootummaan Hoggantoota olaanoo dabalatee miseensotni ABO fi KFO guutummaatti akka hidhaman ajaja dabarse. Mootummaan Dr Abiyyiin durfamu ajjeefamuu artist Hacaaluu Hundeessaan booda Hoggantoota olaanoo jaarmiyaalee...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/afaan-oromoo/mootummaan-hoggantoota-olaanoo-dabalatee-miseensotni-abo-fi-kfo-guutummaatti-akka-hidhaman-ajaja-dabarse/">View Post</a></div></div></div></div></div></div></div></div></div></div></div></div><div class="vc_column tdi_137_cb3 wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>.tdi_137_cb3{vertical-align:baseline;}.tdi_137_cb3 .wpb_wrapper,
.tdi_137_cb3 .wpb_wrapper .tdc-elements{display:block;}.tdi_137_cb3 .wpb_wrapper .tdc-elements{width:100%;}.tdi_137_cb3 .wpb_wrapper{height:auto;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_137_cb3{width:30% !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_137_cb3{width:28% !important;}
}</style><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_138_071 td-pb-border-top td_block_template_2 td-fix-index" data-td-block-uid="tdi_138_071">
<style>.td-theme-wrap .tdi_138_071 .td-block-title > *,
.td-theme-wrap .tdi_138_071 .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_138_071 .td-subcat-item a:hover, .td-theme-wrap .tdi_138_071 .td-subcat-item .td-cur-simple-item, .td-theme-wrap .tdi_138_071 .td-subcat-dropdown:hover .td-subcat-more span, .td-theme-wrap .tdi_138_071 .td-subcat-dropdown:hover .td-subcat-more i{color:#ffffff;}
.td-theme-wrap .tdi_138_071 .td-subcat-dropdown ul:after{background-color:#ffffff;}
.td-theme-wrap .tdi_138_071 .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_138_071 .td_quote_on_blocks, .td-theme-wrap .tdi_138_071 .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_138_071 .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_138_071 .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_138_071 .td-instagram-user a{color:#ffffff;}
.td-theme-wrap .tdi_138_071 .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_138_071 .td-load-more-wrap a:hover{background-color:#ffffff;border-color:#ffffff;}
.td-theme-wrap .tdi_138_071 .td-read-more a, .td-theme-wrap .tdi_138_071 .td-weather-information:before, .td-theme-wrap .tdi_138_071 .td-weather-week:before, .td-theme-wrap .tdi_138_071 .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_138_071 .td-post-category, .td-theme-wrap .tdi_138_071 .td-post-category:hover{background-color:#ffffff;}
.tdi_138_071{margin-bottom:20px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_138_071{margin-bottom:-5px !important;}
}
@media(min-width:1019px) and (max-width:1140px){
.tdi_138_071{margin-bottom:0px !important;}
}</style>
<style>.tdi_138_071 .td-block-title a, .tdi_138_071 .td-block-title span{font-family:Volkhov !important;font-size:20px !important;font-weight:400 !important;}
@media(min-width:1019px) and (max-width:1140px){
.tdi_138_071 .td-block-title a, .tdi_138_071 .td-block-title span{font-family:Volkhov !important;font-size:19px !important;font-weight:400 !important;}
}
@media(min-width:768px) and (max-width:1018px){
.tdi_138_071 .td-block-title a, .tdi_138_071 .td-block-title span{font-family:Volkhov !important;font-size:18px !important;font-weight:400 !important;}
}</style><h4 class="td-block-title"><span class="td-pulldown-size">Popular Articles</span></h4></div><div class="td_block_wrap td_flex_block_1 tdi_139_4e5 td-pb-border-top td_block_template_4 td_ajax_preloading_preload td_flex_block" data-td-block-uid="tdi_139_4e5">
<style>.td-theme-wrap .tdi_139_4e5 .td-pulldown-filter-link:hover, .td-theme-wrap .tdi_139_4e5 .td-subcat-item a:hover, .td-theme-wrap .tdi_139_4e5 .td-subcat-item .td-cur-simple-item, .td-theme-wrap .tdi_139_4e5 .td-subcat-dropdown:hover .td-subcat-more span, .td-theme-wrap .tdi_139_4e5 .td-subcat-dropdown:hover .td-subcat-more i{color:#e3382b;}
.td-theme-wrap .tdi_139_4e5 .td-block-title > *:before{border-color:#e3382b transparent transparent transparent;}
.td-theme-wrap .tdi_139_4e5 .td-block-title > *{background-color:#e3382b;}
.td-theme-wrap .tdi_139_4e5 .td_module_wrap:hover .entry-title a, .td-theme-wrap .tdi_139_4e5 .td_quote_on_blocks, .td-theme-wrap .tdi_139_4e5 .td-opacity-cat .td-post-category:hover, .td-theme-wrap .tdi_139_4e5 .td-opacity-read .td-read-more a:hover, .td-theme-wrap .tdi_139_4e5 .td-opacity-author .td-post-author-name a:hover, .td-theme-wrap .tdi_139_4e5 .td-instagram-user a{color:#e3382b;}
.td-theme-wrap .tdi_139_4e5 .td-next-prev-wrap a:hover, .td-theme-wrap .tdi_139_4e5 .td-load-more-wrap a:hover{background-color:#e3382b;border-color:#e3382b;}
.td-theme-wrap .tdi_139_4e5 .td-read-more a, .td-theme-wrap .tdi_139_4e5 .td-weather-information:before, .td-theme-wrap .tdi_139_4e5 .td-weather-week:before, .td-theme-wrap .tdi_139_4e5 .td-exchange-header:before, .td-theme-wrap .td-footer-wrapper .tdi_139_4e5 .td-post-category, .td-theme-wrap .tdi_139_4e5 .td-post-category:hover{background-color:#e3382b;}
.tdi_139_4e5{margin-bottom:0px !important;}
@media(min-width:768px) and (max-width:1018px){
.tdi_139_4e5{margin-top:-8px !important;}
}</style>
<style>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</style><div class="td-block-title-wrap"></div><div id=tdi_139_4e5 class="td_block_inner td-mc1-wrap">
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/" rel="bookmark" class="td-image-wrap" title="New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf"><span class="entry-thumb td-thumb-css" style="background-image: url(https://ayyaantuu.org/wp-content/uploads/2019/09/the-hijacked-revolution.jpg)"></span></a></div></div><div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/afaan-oromoo/" class="td-post-category">Afaan Oromoo</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/" rel="bookmark" title="New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf">New Book: የተጠለፈ ትግል (The hijacked revolution) in pdf</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-09-03T23:16:23-04:00" >September 4, 2019</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/#comments">4</a></span> </span></div><div class="td-excerpt">Book: የተጠለፈ ትግል (The hijacked revolution) in PDF Via Aba Orma, September 3, 2019 የተጠለፈ ትግል (The hijacked revolution) Author: Mudhin Siraj Pages: 152 Language: Amharic Year: July 2019 To...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/afaan-oromoo/new-book-%e1%8b%a8%e1%89%b0%e1%8c%a0%e1%88%88%e1%8d%88-%e1%89%b5%e1%8c%8d%e1%88%8d-the-hijacked-revolution-in-pdf/">View Post</a></div></div></div></div><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/" rel="bookmark" class="td-image-wrap" title="PM Abiy Ahmed says African Americans live in the past"><span class="entry-thumb td-thumb-css" style="background-image: url(https://ayyaantuu.org/wp-content/uploads/2020/06/abiyahmedq-696x392.jpg)"></span></a></div></div><div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/amharic/" class="td-post-category">Amharic</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/" rel="bookmark" title="PM Abiy Ahmed says African Americans live in the past">PM Abiy Ahmed says African Americans live in the past</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-07T14:52:04-04:00" >June 7, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/#comments">9</a></span> </span></div><div class="td-excerpt">PM Abiy Ahmed says African Americans live in the past In the first part of this video, Ethiopia’s Prime Minister Abiy Ahmed Ali (Nobel Peace...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/amharic/pm-abiy-ahmed-says-african-americans-live-in-the-past/">View Post</a></div></div></div></div><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
<div class="td-module-container td-category-pos-above">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/" rel="bookmark" class="td-image-wrap" title="Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed"><span class="entry-thumb td-thumb-css" style="background-image: url(https://ayyaantuu.org/wp-content/uploads/2020/07/JustinDrapeauCanadien-696x364.jpg)"></span></a></div></div><div class="td-module-meta-info">
<a href="https://ayyaantuu.org/category/english/" class="td-post-category">English</a>
<h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/" rel="bookmark" title="Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed">Ethnic cleansing continued in Oromia Regional State by Abiy Ahmed</a></h3>
<div class="td-editor-date"> <span class="td-author-date"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-12T13:08:15-04:00" >July 12, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/#comments">3</a></span> </span></div><div class="td-excerpt">Ethnic cleansing continued in Oromia Regional State by Ethiopian government lead by Dr. Abiy Ahmed, Prime Minister of Ethiopia July 10, 2020 The Right Honourable Justin...</div><div class="td-read-more"> <a href="https://ayyaantuu.org/english/ethnic-cleansing-continued-in-oromia-regional-state-by-abiy-ahmed/">View Post</a></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div><div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_1 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/" rel="bookmark" class="td-image-wrap" title="Ethiopian Rebel Group Denies Role in Singer’s Death"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC" alt="Rebel Group" title="Ethiopian Rebel Group Denies Role in Singer’s Death" data-type="image_tag" data-img-url="https://ayyaantuu.org/wp-content/uploads/2020/07/looted1-324x160.jpg" width="324" height="160"/></a></div></div><h3 class="entry-title td-module-title"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/" rel="bookmark" title="Ethiopian Rebel Group Denies Role in Singer’s Death">Ethiopian Rebel Group Denies Role in Singer’s Death</a></h3>
<div class="td-module-meta-info"> <span class="td-post-author-name"><a href="https://ayyaantuu.org/author/admin/">Admin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-19T07:48:56-04:00" >July 19, 2020</time></span> <span class="td-module-comments"><a href="https://ayyaantuu.org/english/ethiopian-rebel-group-denies-role-in-singers-death/#respond">0</a></span></div></div></div></div><noscript id="wpfc-google-fonts"><link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700%7CPoppins%3A400%2C500%2C600%7CVolkhov%3A400%7COswald%3A700%2C600%7COpen+Sans%3A500%2C700%7CMerriweather%3A700%2C600%2C400&#038;display=swap&#038;ver=10.3.5' type='text/css' media='all'/>
</noscript>
<script>var monsterinsights_frontend={"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/ayyaantuu.org","hash_tracking":"false"};</script>
<script>var data={"licence":""};</script>
<script>var wpcf7={"apiSettings":{"root":"https:\/\/ayyaantuu.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script>
<script data-cfasync="false">var mi_version='7.11.0';
var mi_track_user=true;
var mi_no_track_reason='';
var disableStr='ga-disable-UA-85702685-1';
function __gaTrackerIsOptedOut(){
return document.cookie.indexOf(disableStr + '=true') > -1;
}
if(__gaTrackerIsOptedOut()){
window[disableStr]=true;
}
function __gaTrackerOptout(){
document.cookie=disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr]=true;
}
if('undefined'===typeof gaOptout){
function gaOptout(){
__gaTrackerOptout();
}}
if(mi_track_user){
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-85702685-1', 'auto');
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('require', 'linkid', 'linkid.js');
__gaTracker('send','pageview');
}else{
console.log("");
(function(){
var noopfn=function(){
return null;
};
var noopnullfn=function(){
return null;
};
var Tracker=function(){
return null;
};
var p=Tracker.prototype;
p.get=noopfn;
p.set=noopfn;
p.send=noopfn;
var __gaTracker=function(){
var len=arguments.length;
if(len===0){
return;
}
var f=arguments[len-1];
if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){
console.log('Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason);
return;
}
try {
f.hitCallback();
} catch (ex){
}};
__gaTracker.create=function(){
return new Tracker();
};
__gaTracker.getByName=noopnullfn;
__gaTracker.getAll=function(){
return [];
};
__gaTracker.remove=noopfn;
window['__gaTracker']=__gaTracker;
})();
}</script>
<script src='//ayyaantuu.org/wp-content/cache/wpfc-minified/7c4hphwo/rkz.js'></script>
<script src='https://content.uplynk.com/75f196bd-dadf-48bc-aba0-d8c27014ab7f.m3u8?ver=5.4.2'></script>
<script src='//ayyaantuu.org/wp-content/cache/wpfc-minified/1bqcfjug/rkz.js'></script>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>window.tdb_globals={"wpRestNonce":"f4b6f7b9d3","wpRestUrl":"https:\/\/ayyaantuu.org\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script>
<script>window.tdwGlobal={"adminUrl":"https:\/\/ayyaantuu.org\/wp-admin\/","wpRestNonce":"f4b6f7b9d3","wpRestUrl":"https:\/\/ayyaantuu.org\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script>
<script>var tdBlocksArray=[];
function tdBlock(){
this.id='';
this.block_type=1;
this.atts='';
this.td_column_number='';
this.td_current_page=1;
this.post_count=0;
this.found_posts=0;
this.max_num_pages=0;
this.td_filter_value='';
this.is_ajax_running=false;
this.td_user_action='';
this.header_color='';
this.ajax_pagination_infinite_stop='';
}
(function(){
var htmlTag=document.getElementsByTagName("html")[0];
if(navigator.userAgent.indexOf("MSIE 10.0") > -1){
htmlTag.className +=' ie10';
}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){
htmlTag.className +=' ie11';
}
if(navigator.userAgent.indexOf("Edge") > -1){
htmlTag.className +=' ieEdge';
}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){
htmlTag.className +=' td-md-is-ios';
}
var user_agent=navigator.userAgent.toLowerCase();
if(user_agent.indexOf("android") > -1){
htmlTag.className +=' td-md-is-android';
}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){
htmlTag.className +=' td-md-is-os-x';
}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){
htmlTag.className +=' td-md-is-chrome';
}
if(-1!==navigator.userAgent.indexOf('Firefox')){
htmlTag.className +=' td-md-is-firefox';
}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){
htmlTag.className +=' td-md-is-safari';
}
if(-1!==navigator.userAgent.indexOf('IEMobile')){
htmlTag.className +=' td-md-is-iemobile';
}})();
var tdLocalCache={};
(function (){
"use strict";
tdLocalCache={
data: {},
remove: function (resource_id){
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id){
return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;
},
get: function (resource_id){
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData){
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id]=cachedData;
}};})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/ayyaantuu.org\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.3.5";
var td_get_template_directory_uri="https:\/\/ayyaantuu.org\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="6c5bffaecd";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script>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</script>
<script src='//ayyaantuu.org/wp-content/cache/wpfc-minified/1p92qbg5/rkz.js'></script>
<script>
jQuery().ready(function (){
var tdbMenuItem=new tdbMenu.item();
tdbMenuItem.blockUid='tdi_33_4de';
tdbMenuItem.jqueryObj=jQuery('.tdi_33_4de');
tdbMenuItem.isMegaMenuParentPos=true;
tdbMenu.addItem(tdbMenuItem);
});
jQuery().ready(function (){
var tdbMenuItem=new tdbMenu.item();
tdbMenuItem.blockUid='tdi_48_430';
tdbMenuItem.jqueryObj=jQuery('.tdi_48_430');
tdbMenuItem.isMegaMenuParentPos=true;
tdbMenu.addItem(tdbMenuItem);
});</script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
</body>
</html><!-- WP Fastest Cache file was created in 6.2597408294678 seconds, on 19-07-20 8:08:40 --><!-- via php -->